After upgrade to ISPconfig 3.2 can not receive mails

Discussion in 'General' started by Robin.k, Oct 22, 2020.

  1. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    This thread has gotten very off track of what the original poster/issue was, please start a new thread for new problems in the future.

    Do you have backup files made during the 3.2 update? Can you post your previous main.cf (prior to updating), or at least the smtpd_helo_restrictions setting. Also check the /usr/local/ispconfig/server/conf-custom/install/ directory and ensure there's not a postfix template there.

    It is set in /etc/dovecot/dovecot.conf (you'll have to make a conf-custom template to make your change effective after ispconfig updates).
     
  2. Robin.k

    Robin.k Member

    Hi @Jesse Norell

    I did not make any backup during 3.2 update. (i will indeed do this next time)

    In /etc/dovecot/dovecot.conf
    I changed client limit to 1500. And reboot. After the reboot I still get the warning.
    "mail dovecot: config: Warning: service auth { client_limit=1000 } is lower than required under max. load ( 012)

    }
    lmtp_rcpt_check_quota = yes
    service imap-login {
    client_limit = 1500
    process_limit = 512

    Is the change in "dovecot.conf" correct?
     
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You only set this for imap-login, try setting it globally instead (so not within any brackets)
     
  4. Robin.k

    Robin.k Member

    I don't understand, can you post an example!
    When I delete the brackets, Dovecot gives me an error when restarting Dovecot.

    _listener /var/spool/postfix/private/dovecot-lmtp {
    group = postfix
    mode = 0600
    user = postfix
    # For higher volume sites, it may be desirable to increase the number of active listener processes.
    # A range of 5 to 20 is probably good for most sites
    # process_min_avail = 5
    }


    lmtp_rcpt_check_quota = yes
    service imap-login
    client_limit = 1500
    process_limit = 500
    }
    protocol imap {
    mail_plugins = quota imap_quota
    auth_verbose = yes
    }
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    No, don't remove the brackets. Undo that change. Put
    Code:
    client_limit = 1500
    at the top of your config (first line), so it is globally configured.
     
  6. Robin.k

    Robin.k Member

    Hi, I put client_limit = 1500 at the top of the dovecot.conf file, but now I can't start Dovecot

    I get this error

    Code:
    -- Unit dovecot.service has begun starting up.
    okt 24 15:44:41 mail.xxx.nl dovecot[8270]: doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 1: Unknown setting
    okt 24 15:44:41 mail.xxx.nl dovecot[8270]: doveconf: Error: managesieve-login: dump-capability process returned 89
    okt 24 15:44:41 mail.xxx.nl dovecot[8270]: doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 1: Unknown setting
    okt 24 15:44:41 mail.xxx.nl systemd[1]: dovecot.service: Control process exited, code=exited status=89
    okt 24 15:44:41 mail.xxx.nl systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
    -- Subject: Unit dovecot.service has failed
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit dovecot.service has failed.
    
     
  7. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Please share the content of your dovecot.conf.
     
  8. Steini86

    Steini86 Active Member

    To change client limit for all dovecot services you need to use the 'default' parameter:
    default_client_limit = 1500
    This is usually done in /etc/dovecot/conf.d/10-master.conf (there should be a commented value right in the first lines of these files. uncomment and change them)
    Or on a per-service level in /etc/dovecot/dovecot.conf. But then you obviously have to put it into the "service auth {" brackets, not the "dovecot-lmtp". The error message told you about the "service auth client limit"
     
    Th0m likes this.
  9. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Thanks for clarifying @Steini86, I don't use it myself and thought it was default_client_limit aswell but it seemed like client_limit was valid to use globally. :)
     
    Steini86 likes this.
  10. Robin.k

    Robin.k Member

    Ok thanks.

    In E-mail warn Logs I get the message "postfix/smtpd[20659]: warning: hostname server.xxx.nl does not resolve to address 196.152.156.xx. DNS and reverse DNS works with online test MX tools. What is wrong?

    Thanks
     
  11. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    It means exactly what's there. I can't verify it because you don't share the hostname and ip address. Can it be that you just added the record and it has to propagate?
     
  12. Robin.k

    Robin.k Member

    Yes I added just added the record, I will wait for an hour or so...
     
  13. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    DNS propagation can take some time. Sometimes even a day or longer. You can check it on your server with
    Code:
    dig server.xxx.nl
     
  14. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    niemand-glaumy likes this.

Share This Page