After Updating to CentOS 6.1 php seems to be quite a pain

Discussion in 'General' started by Thang, Dec 16, 2011.

  1. Thang

    Thang New Member

    On some sites i get the following errors and only see white pages or error pages

    PHP Warning: require(): open_basedir restriction in effect. File() is not within the allowed path(s):

    Any Idea ? It did work before the update.
     
  2. falko

    falko Super Moderator

    Please check the open_basedir setting on the Options tab of your websites in ISPConfig.
     
  3. Thang

    Thang New Member

    Doesn´t look any different then before the update.

    I did even try to delete it completely, but that does not seem to work.

    Perhaps the problem is with the user wordpress version.
    Although i would expect it to still work when doing a minor version change of cents.


    I found the solution, but it does not work from ISP Config Interface for me

    apc.include_once_override 0

    How would i set that ?
     
    Last edited: Dec 18, 2011
  4. till

    till Super Moderator

    This is set in the php.ini file, on centos it should be /etc/php,ini if I remeber correctly.
     
  5. Thang

    Thang New Member

    Hi Till sure i know that, but i thought i would set that within the custom php.ini settings for the one vhost.

    But it does not appear in the ghosts httpd.conf


    Found it myself. thx
     
    Last edited: Dec 21, 2011

Share This Page