After update

Discussion in 'Installation/Configuration' started by Morons, Nov 14, 2014.

  1. Morons

    Morons Member

    I get this message and my ISP 3 Panel has SSL Issues ofc

     [warn] NameVirtualHost *:443 has no VirtualHosts
    My /etc/apache2/sites-available/ispconfig.conf only contain (last 2 lines)

    Alias /awstats-icon "/usr/share/awstats/icon"
    NameVirtualHost *:80
    NameVirtualHost *:443
    How can i Fix this as I dont know what need to be there :mad:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not an error. This message means that apache is ready configured to host sl sites on *.

    Thats good as it means that this file is correct.
  3. Morons

    Morons Member


    Then Im Confused about why I get the message when i go to my https://isp3server.tdl:8080/

    I have run and made new Cert and Still get this error !
    Other Sites seem to run fine, I just cant manage my users.:confused:

    Secure Connection Failed

    An error occurred during a connection to SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The message "[warn] NameVirtualHost *:443 has no VirtualHosts" in not related to your broken ssl cert at all.

    The new error message that you posted now means that the ssl cert is broken or does not exist and therefor cant be read by apache. You can get a broken sl cert e.g. when you enter values in the openssl questions that openssl cant understand and therefor cant craete a ssl cert.

    You should create a new ssl cert to fix that.
  5. Morons

    Morons Member

  6. Morons

    Morons Member

    Is there a Way I can modify the Control panel to accept port 80 instead?
    As a quick fix?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    you can not use port 80 but you can use http. just comment out all lines that start with SSL in the ispconfig vhost and restart apache.
  8. Morons

    Morons Member


    It does not take the http:// and immidiatly reload the https:// in my browser as if it only allow https

    Sorry for the bother and Noob questions

Share This Page