After Update Issue

Discussion in 'Installation/Configuration' started by kendel, Feb 25, 2013.

  1. kendel

    kendel New Member

    Seems my websites still work, even the Proxy to mail server still works but, ispconfig on the panel server stopped working.

    I did all the minor server updates of ispconfig first. then I did the panel server last (which hosts the ispconfig control panel).

    The panel server is no longer responding. not on the https or http which I self created to the /var/www/ispconfig folder. I left everything default as it was on the update since I had made no changes initially except the original default port on the panel server which I changed from 8080 to 11000 (originally). But wit the update it was reset to 8080.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please check the apache error.log. Moste likely a part of the fastcgi setup is missing.
     
  3. siucdude911

    siucdude911 New Member

    Same issue here, and I can't access the CP anymore,

    Forbidden
    You don't have permission to access / on this server.


    [Mon Feb 25 17:52:16 2013] [error] [client 10.0.0.103] client denied by server configuration: /var/www/

    the error message and the log of the error,
    It worked like a charm before the update...

    This is the only other thing i found related to this error message.
    http://www.howtoforge.com/forums/showthread.php?t=60025
     
  4. kendel

    kendel New Member

    I did some troubleshooting and figured out that when the update happened ISPConfig created a new virual host using port 8080 of the exact location I was using for port 80, which somehow conflicted, so I had to delete my custom port 80. given that, How can I make this work for me:

    <VirtualHost ipaddress:443>
    ServerName host1.domain.com
    ProxyPreserveHost On
    ProxyRequests Off
    ProxyPass / https://privateip:8080/
    ProxyPassReverse / https://privateip:8080/

    SSLProxyEngine on
    SSLEngine on
    SSLCertificateFile /etc/ssl/certs/server.crt
    SSLCertificateKeyFile /etc/ssl/private/server.key


    Whenever I try to use port 443 on my webserver to forward proxy, the apache server gets an error:

    Failed to start apache :

    * Starting web server apache2
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
    ...fail!

    Initially I had the control panel running on port 80. and it worked so I left it alone.
     
  5. siucdude911

    siucdude911 New Member

    Well here is more info,
    I get this after I made changes to the hostfile

    [Mon Feb 25 22:08:26 2013] [error] [client 10.0.0.103] PHP Warning: require_once(/usr/local/ispconfig/interface/lib/config.inc.php): failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31
    [Mon Feb 25 22:08:26 2013] [error] [client 10.0.0.103] PHP Fatal error: require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Seems as if you have more then one Listen statement for port 80 in your apache configuration.

    Please post the output of:

    ls -la /usr/local/ispconfig/interface/lib/config.inc.php
     
  7. kendel

    kendel New Member

    the thing is, I am trying to use port 443. not 80...
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The error message is about port 80, not 443. So there must be a duplicate Listen statement for port 80 somewhere which prevents apache to start.
     
  9. siucdude911

    siucdude911 New Member

    root@pc:/# ls -la /usr/local/ispconfig/interface/lib/config.inc.php
    -rw------- 1 ispconfig ispconfig 6671 Feb 25 12:58 /usr/local/ispconfig/interface/lib/config.inc.php
    root@pc:/#
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thats ok.

    Please install the following patch update to see if this fixes your issue:

    http://www.howtoforge.com/forums/showpost.php?p=292661&postcount=22
     
  11. siucdude911

    siucdude911 New Member

    Till,
    I followed your work around from http://www.howtoforge.com/forums/showthread.php?t=60691
    and it worked, i can now get into my ISP cp , you did mention that there is a problem with php-fcgi has a problem to connect to mysql. is there anything i should worry about at this point,
    Thank You, i will continue to test on my box and deploy if everything else works good.
    TJ
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No. As we found out it is a bug in the OO version of the php mysqli driver which affects only two specific php versions according to the php manual and we implemented a workaround for that which is available in the bugfix version in #10 of this thread.
     
  13. kendel

    kendel New Member

    I removed all changes and went back to default but now it won't start at all these are my errors:

    Failed to start apache :

    * Starting web server apache2
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
    ...fail!
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Check with netstat - tap which program is listening on port 80 and stop or kill it, then try to start apache again.
     
  15. kendel

    kendel New Member

    Does this need to be installed on all servers?
     
  16. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You mwan the ispconfig 3.0.5 update on a multiserver setup? If you run a multiserver setup, then a update has to be installed on all servers.
     
  17. kendel

    kendel New Member

    I got it thx.....

    last question my regular ReverseProxy is no longer working...

    I have a panel server with ispconfig and judging from the update it changed the VirtualHost for the ispconfig entirely...

    so I am trying to create the ReverseProxy again using what is already there:
    Code:
     ServerAdmin webmaster@localhost
      
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
      
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
      </IfModule>
      
    #  <IfModule mod_php5.c>
    #    DocumentRoot /usr/local/ispconfig/interface/web/
    #    AddType application/x-httpd-php .php
    #    <Directory /usr/local/ispconfig/interface/web>
    #      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
    #      Options FollowSymLinks
    #      AllowOverride None
    #      Order allow,deny
    #      Allow from all
    #	  php_value magic_quotes_gpc        0
    #    </Directory>
    #  </IfModule>
      
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
      
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      SSLEngine On
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    I have not made any changes to it.. I simply created a Virtual host on the webserver for ReverseProxy.

    <VirtualHost *:80>
    ServerName cp.example.com

    ProxyRequests Off
    ProxyPreserveHost On
    ProxyPass / https://192.168.10.150:8080/
    ProxyPassReverse / https://192.168.10.150:8080/
    </VirtualHost>


    But basically I get:
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache/2.2.22 (Ubuntu) Server at cp.example.com Port 80


    How can I fix that?
     

Share This Page