After ubuntu upgrade : Status of Services gives false info

Discussion in 'General' started by Enzo2424, Sep 18, 2018.

  1. Enzo2424

    Enzo2424 New Member

    Hi all,

    I ugraded from 16.04 to 18.04 (latest LTS) and everything went ok (except Roundcube).
    However, If I go to see Status of Services in the 'Monitor' section, it says that Web, FTP, SMTP, POP3 and IMAP servers are Offline, although they are online (DNS and mySQL servers are recognized Online).

    Also, in Monitor section, it says Ubuntu LTS UNKNOWN - ISPConfig 3.1.8p1

    Am I alone with this problem ? anyone have an idea what's up on my server's ISPConfig ?

    I'd be tempted by re-running ISPConfig configuration, but don't want to botch things up.

    Thanks for any help.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you also done all the setups described in Perfect Server Guide for ubuntu 18.04?
     
    ahrasis likes this.
  3. Enzo2424

    Enzo2424 New Member

    Oh, ok; after upgrade, need to redo the configuration as per tuto... will do :) Thanks
     
  4. Enzo2424

    Enzo2424 New Member

    I've done all the setups (indeed a couple of packages upgraded) that were in the Guide.
    Now, I get
    Error
    One or more needed services are offline

    FTP-server offline

    I did a restart on pureftpd and got this : pure-ftpd[5700]: ([email protected]?) [ERROR] Sorry, but that file doesn't exist: [/etc/ssl/private/pure-ftpd.pem]

    however, when I go look in there, the file exists...

    I tried changing owner from root:root to root:ssl-cert, but no difference, so I put back to owner root:root as it was...

    any ideas ? Thanks :)
     
    Last edited: Sep 19, 2018
  5. Enzo2424

    Enzo2424 New Member

    I got it .
    Renamed pem file to .old and regenerated a new one... restarted pureftp and all is ok.. I suppose ispconfig3 will refresh status shortly. At least everything works now :)
     
    ahrasis likes this.

Share This Page