After restarting iscsi remote drive are not accesible in an IP6 disabled centos 5.4

Discussion in 'Kernel Questions' started by aneeshsudev, Nov 19, 2010.

  1. aneeshsudev

    aneeshsudev New Member

    Hi

    i have installed one HP blade server with "Linux version 2.6.18-164.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-46)) 0000001 SMP Thu Sep 3 03:28:30 EDT 2009 " CentOS release 5.4 (Final) .I have disabled the IP6 with these commands by adding these in /etc/modeprob.conf

    alias net-pf-10 off
    alias ipv6 off
    options ipv6 disable=1

    after that i installed iscsi and pointed towards one netapp .then i created lvm in the system with netapp drive .

    when ever i restart a server or restart ISCSCI after that i am not not able to access the LVM what i created . Please help me

    Additional Information dsmg log

    EXT3 FS on dm-2, internal journal
    EXT3-fs: recovery complete.
    EXT3-fs: mounted filesystem with ordered data mode.
    cxgb3i: tag itt 0x1fff, 13 bits, age 0xf, 4 bits.
    iscsi: registered transport (cxgb3i)
    cnic: Unknown symbol __ipv6_addr_type
    cnic: Unknown symbol ip6_route_output
    iscsi: registered transport (iser)
    scsi1 : iSCSI Initiator over TCP/IP
    Vendor: NETAPP Model: LUN Rev: 7310
    Type: Direct-Access ANSI SCSI revision: 04
    SCSI device sdb: 629225472 512-byte hdwr sectors (322163 MB)
    sdb: Write Protect is off
    sdb: Mode Sense: bd 00 00 08
    SCSI device sdb: drive cache: write through
    SCSI device sdb: 629225472 512-byte hdwr sectors (322163 MB)
    sdb: Write Protect is off
    sdb: Mode Sense: bd 00 00 08
    SCSI device sdb: drive cache: write through
    sdb: sdb1
    sd 1:0:0:0: Attached scsi disk sdb
    sd 1:0:0:0: Attached scsi generic sg0 type 0



    [root@wapdb-node2 aneesh]# service iscsi restart
    Logging out of session [sid: 2, target: iqn.1986-03.com.ibm:sn.135057127, portal: 10.0.104.202,3260]
    Logout of [sid: 2, target: iqn.1986-03.com.ibm:sn.135057127, portal: 10.0.104.202,3260]: successful
    Stopping iSCSI daemon:
    iscsid dead but pid file exists [ OK ]
    Starting iSCSI daemon: WARNING: Error inserting libiscsi2 (/lib/modules/2.6.18-164.el5/kernel/drivers/scsi/libiscsi2.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting bnx2i (/lib/modules/2.6.18-164.el5/kernel/drivers/scsi/bnx2i/bnx2i.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    [ OK ]
    [ OK ]
    Setting up iSCSI targets: Logging in to [iface: default, target: iqn.1986-03.com.ibm:sn.135057127, portal: 10.0.104.202,3260]
    Login to [iface: default, target: iqn.1986-03.com.ibm:sn.135057127, portal: 10.0.104.202,3260]: successful
    [ OK ]
    [root@wapdb-node2 aneesh]#



    [root@wapdb-node2 /]# lvdisplay
    /dev/MySql/MySql: read failed after 0 of 4096 at 0: Input/output error
    --- Logical volume ---
    LV Name /dev/MySql/MySql
    VG Name MySql
    LV UUID dZ4DCD-qcxM-KnCt-xsrK-KyeM-pndo-0a5T9y
    LV Write Access read/write
    LV Status available
    # open 1
    LV Size 300.00 GB
    Current LE 76800
    Segments 1
    Allocation inherit
    Read ahead sectors auto
    - currently set to 256
    Block device 253:2
     

Share This Page