After Install: Mail not working and FTP strange

Discussion in 'Installation/Configuration' started by Raffnix, Feb 2, 2006.

  1. Raffnix

    Raffnix New Member

    Unfortunately it still exists.

    I installed Debian 3.1 (Perfect Setup Howto) and ISPconfig yesterday on a local server from zero - Result: FTP online, connection with client and WebFTP possible
    I installed the same today on my production server (again), where I start with a minimal Debian 3.1 Image and continue then too with Perfect Setup Howto - Result: FTP offline, connection with client possible, with WebFTP: "Could not connect to localhost."

    :(
     
  2. falko

    falko Super Moderator

    You already have
    Code:
    SocketBindTight on
    in your /etc/proftpd.conf, right?
    Can you add this:
    Code:
    <VirtualHost 127.0.0.1>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    
    right before
    Code:
    Include /etc/proftpd_ispconfig.conf
    and restart ProFTPd?
     
  3. Raffnix

    Raffnix New Member

    Thanks, but:

    I added the lines, I stopped proftpd (netstat showed no more ftp running), then I restarted ISPconfig_server which itself started proftpd (netstat now showed ftp listening on both: domain and localhost) ...
    but WebFTP still could not connect to localhost *sigh*
     
  4. falko

    falko Super Moderator

    Do you see any error messages in the log files when you try to connect with Web-FTP?
     
  5. louisgag

    louisgag New Member

    I managed to stolve my similar problem by adding this directive to my proftpd.conf or proftpd_ispconfig.conf file (in the server section)

    Bind localhost
     

Share This Page