After install error(s) by starting ISPconfig

Discussion in 'Installation/Configuration' started by BvO, Jan 13, 2007.

  1. BvO

    BvO New Member

    Hi,

    I tried to install ISPconfig on fresh Debian 3.1 machine (followed falko's howto).

    Everything goes well until it starts itself, see the logging:


    Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in /downloads/install_ispconfig/install.php on line 1084
    Could not connect to MySQL server
    Restarting some services...
    Stopping mail transport agent: Postfix.
    Starting mail transport agent: Postfix.
    Restarting ProFTPD ftp daemon.proftpd.
    ..proftpd.
    done.
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started

    Warning: include(/home/admispconfig/ispconfig/lib/config.inc.php): failed to open stream: No such file or directory in /root/ispconfig/scripts/lib/config.inc.php on line 30

    Warning: include(): Failed opening '/home/admispconfig/ispconfig/lib/config.inc.php' for inclusion (include_path='.:') in /root/ispconfig/scripts/lib/config.inc.php on line 30
    Could not connect to MySQL server!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to


    Have anybody a solution to this?

    Mysql is running, the ISPconfig apache also, here is the result off the webpage:


    Warning: include(../lib/config.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/web/login.php on line 30

    Warning: include() [function.include]: Failed opening '../lib/config.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/web/login.php on line 30

    Warning: require_once(login/lib/lang/.lng) [function.require-once]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/web/login.php on line 31

    Fatal error: require_once() [function.require]: Failed opening required 'login/lib/lang/.lng' (include_path='.:') in /home/admispconfig/ispconfig/web/login.php on line 31

    Thanks in advance!
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you update your mysql server after you installed ISPConfig or did you install a another mysql version (mysql5) then the mysql4 version that falko installed in the howto?
     
  3. BvO

    BvO New Member

    Yes i upgraded to mysql 5 and php5 from (dotdeb.org), before I installed ISPconfig.
    Is it possible to let it run with this, or do I have to uninstall this and just install the packages form (falko)?

    Thanks in advance!

    BvO
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You can run ISPConfig with mysql5 as well, but you will have to install the mysql5 developemnt librararys then to install ISPConfig.

    Please run:

    apt-get install libmysqlclient15-dev

    Before you try to install ISPConfig again, run:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    and delete the ISPConfig mysql database, if it exists.
     
  5. BvO

    BvO New Member


    Till, it worked out for me!
    Thanks for the advice!

    BvO
     

Share This Page