after creating a site and mysql db/user can't connect

Discussion in 'Server Operation' started by Ryein, Jul 13, 2016.

  1. Ryein

    Ryein New Member

    I can't connect my wordpress site to the database. I can login with phpmyadmin, but it doesn't work past that.

    Can some one help debug?

    When I login as root user I can use sudo service mysql status and it is running.

    In one of the log files all I could find that looks strange is this.
    'user' entry '[email protected]' has both a password and an authentication plugin
    Last edited: Jul 13, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    try to login to phpmyadmin as root user and then check if the database nd mysql user that you added for the wordpress site are there.
  3. ranopalepu

    ranopalepu New Member

    Usually, your database root user does have a password, which will be required by both phpmyadmin and wordpress. As you are using phpmyadmin, I assume you are aware of that password.

    Wordpress required the database user (which I highly recommend shouldn't be the root user), the host (in this case likely "localhost"), the password (should be the one you use for phpmyadmin), and the name of a database (the database user requires certain rights on this database, however root is likely to have them).

    To help you further: What error messages does WordPress print out in your attempts? If no message appears, check that php.ini has error reporting turned on (temporarily) and change your wordpress configuration to DEBUG mode. Furthermore, what are your mysql logs saying? (You can likely find them under /var/log if you are on a Debian system.)

Share This Page