After APS package update Invalid ID wordpress install

Discussion in 'General' started by -IFFI_, Aug 8, 2013.

  1. -IFFI_

    -IFFI_ New Member

    Hi everyone,

    I use ISPconfig Debian 7 64bit server.

    Yesterday upgraded APS package list and now if I want to install WordPress i get error "INVALID ID"

    APS package list was wordpress old version 3.5 now updated to version 3.6

    it seems that other scripts work, only wordpress get error.

    How to fix this problem?

    Sorri my bad english, i use google trantslator.
  2. almere

    almere Member HowtoForge Supporter

    About what WP version is it going about ?
    I just installed 3.5.2-1 without any problem.
  3. -IFFI_

    -IFFI_ New Member

    Wordpress work nice.

    Problem is ISPconfig-3 APS installers. After APS package upgrade can not install WordPress.


    after than click wordpress link i get error

  4. sjswarts

    sjswarts New Member

    I have the same thing.

    Like the OP, I updated the APS list and then went to install Wordpress but confronted with Invalid ID
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. sjswarts

    sjswarts New Member

    that looks good... I'll try it and post back
  7. greldon

    greldon New Member

    I got the same problem, I have tried the patch indicated above but for now it is not working, someone else?
  8. sjswarts

    sjswarts New Member

  9. Fredrik75

    Fredrik75 New Member

    This a bug that needs to be fixed.

    Unfortunately there is some errors in the patch-file provided in the bug-report, .

    web:/usr/local/ispconfig/interface/lib/classes# patch </root/aps_crawler.diff
    patching file
    patch: **** malformed patch at line 4: $namespaces = $sxe->getDocNamespaces(true);
    Probably the bugtracker that did some changes to the text...

  10. Fredrik75

    Fredrik75 New Member

  11. almere

    almere Member HowtoForge Supporter

    I found the solution...

    open the file: /usr/local/ispconfig/interface/lib/classes/

    Function: getNewestPackageID

    After the line:
    WHERE name = (SELECT name FROM aps_packages WHERE id ".$app->db->quote($id).")
    add the line:
    AND package_status 2
    This solved the problem.
  12. stoute

    stoute New Member

    Thanks for this... been having this problem for a while now. Confirmed WP works now.

Share This Page