After adding a new PHP addon the updater never completes and gives me an error

Discussion in 'ISPConfig 3 Priority Support' started by webguyz, Mar 18, 2020.

  1. webguyz

    webguyz Active Member HowtoForge Supporter

    I added a new PHP ver 7.3 using the sury.org method and everything seemed ok but the update notification never completed

    • datalog_status_d_server_php: 1
    • datalog_status_i_server_php: 1
    • datalog_status_u_server_php: 2
    I ran server.sh manuall and got this error below. Running ISPconfig version 3.1.13

    [email protected]:~# /usr/local/ispconfig/server/server.sh
    18.03.2020-11:19 - WARNING - There is already a lockfile set, but no process running with this pid (74364). Continuing.
    PHP Fatal error: Uncaught Error: Call to undefined function mysqli_init() in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php:83
    Stack trace:
    #0 /usr/local/ispconfig/server/lib/app.inc.php(47): db->__construct()
    #1 /usr/local/ispconfig/server/lib/app.inc.php(216): app->__construct()
    #2 /usr/local/ispconfig/server/server.php(51): require('/usr/local/ispc...')
    #3 {main}
    thrown in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 83
    PHP Fatal error: Uncaught Error: Call to undefined function mysqli_init() in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php:83
    Stack trace:
    #0 /usr/local/ispconfig/server/lib/app.inc.php(47): db->__construct()
    #1 /usr/local/ispconfig/server/lib/app.inc.php(216): app->__construct()
    #2 /usr/local/ispconfig/security/check.php(32): require('/usr/local/ispc...')
    #3 {main}
    thrown in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 83
    [email protected]:~#
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you accidentally replaced the main PHP version of the operating system with a PHP that does not support MySQL. If there is a PHP binary in /usr/local/bin/ folder, then rename or delete that.
     
  3. webguyz

    webguyz Active Member HowtoForge Supporter

    Think your right typed: php --version and got 7.3.15
    [email protected]:~# php --version
    PHP 7.3.15-4+0~20200224.55+debian9~1.gbpbea824 (cli) (built: Feb 24 2020 18:39:46) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.15, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.15-4+0~20200224.55+debian9~1.gbpbea824, Copyright (c) 1999-2018, by Zend Technologies
     
  4. webguyz

    webguyz Active Member HowtoForge Supporter

    Set it back to PHP 7.0 and it updated and server.sh working correctly.
    Thanks!
     

Share This Page