After actualization to .32 my users can't send messages to various destinations

Discussion in 'Installation/Configuration' started by esezako, Apr 17, 2009.

  1. esezako

    esezako New Member

    After update, when send messages my users receiv this message:

    This is the mail system at host xxxxxx.ovh.net.
    >
    > I'm sorry to have to inform you that your message could not
    > be delivered to one or more recipients. It's attached below.
    >
    > For further assistance, please send mail to postmaster.
    >
    > If you do so, please include this problem report. You can
    > delete your own text from the attached returned message.
    >
    > The mail system
    >
    > <[email protected]>: Host or domain name not found.
    > Name
    > service error for name=yyyy.com type=A: Host not
    > found

    What is hapening?
     
    Last edited: Apr 17, 2009
  2. esezako

    esezako New Member

    if i query my server for a mx record don't responds ok.

    root:$ dig yahoo.es MX @my-ip-server


    Code:
    ; <<>> DiG 9.4.1-P1.1 <<>> yahoo.es MX @my-ip-server
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 8155
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;yahoo.es.                      IN      MX
    
    ;; AUTHORITY SECTION:
    es.                     86400   IN      SOA     mydomain.net. admin.es. 2009041501 28800 7200 604800 86400
    
    ;; Query time: 48 msec
    ;; SERVER: my-ip-server#53(my-ip-server)
    ;; WHEN: Fri Apr 17 13:55:33 2009
    ;; MSG SIZE  rcvd: 86
    
    If i query to other my servers (whit the same install) this is the response:

    Code:
    ; <<>> DiG 9.4.1-P1.1 <<>> yahoo.es MX @other-ip
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26241
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 5, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;yahoo.es.                      IN      MX
    
    ;; ANSWER SECTION:
    yahoo.es.               2184    IN      MX      10 e.mx.mail.yahoo.com.
    yahoo.es.               2184    IN      MX      10 f.mx.mail.yahoo.com.
    yahoo.es.               2184    IN      MX      10 g.mx.mail.yahoo.com.
    yahoo.es.               2184    IN      MX      10 a.mx.mail.yahoo.com.
    yahoo.es.               2184    IN      MX      10 b.mx.mail.yahoo.com.
    yahoo.es.               2184    IN      MX      10 c.mx.mail.yahoo.com.
    yahoo.es.               2184    IN      MX      10 d.mx.mail.yahoo.com.
    
    ;; AUTHORITY SECTION:
    yahoo.es.               167784  IN      NS      ns3.yahoo.com.
    yahoo.es.               167784  IN      NS      ns5.yahoo.com.
    yahoo.es.               167784  IN      NS      ns7.yahoo.com.
    yahoo.es.               167784  IN      NS      ns1.yahoo.com.
    yahoo.es.               167784  IN      NS      ns2.yahoo.com.
    
    ;; Query time: 46 msec
    ;; SERVER: other-ip#53(other-ip)
    ;; WHEN: Fri Apr 17 14:06:01 2009
    ;; MSG SIZE  rcvd: 259

    What can i do?

    Please, help!
     
  3. esezako

    esezako New Member

    help, please
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please try other nameservers in your /etc/resolv.conf.
     
  5. esezako

    esezako New Member

    Hi, falko, i have done this but does not solve the problem.
    Can the problem be in the bind?

    Thank's for your time
     
  6. Norman

    Norman Member

    Try other dns servers.

    Are you running debian? Did you upgrade bind too on other systems?

    Bind changed it way it accepts recursive lookups, you need to allow it from the systems you want it allowed from in newer versions of bind.
     
  7. esezako

    esezako New Member

    I have the same version of bind in two servers

    Code:
    /home# nslookup -q=txt -class=CHAOS version.bind. 0
    Server:         0
    Address:        0.0.0.0#53
    
    version.bind    text = "9.3.4-P1.1"
    Where and how i can see if my server accepts recursive lookups?
    If it not do, how i change it?

    Thank's
     
  8. tebokkel

    tebokkel New Member

    Looks to me like you have defined a zone for .ES in your DNS.
    Is that possible?

    Paul
     
  9. esezako

    esezako New Member

    Thank's tebokkel. The problem was, as you said, that i had defined a zone for .ES in my DNS.

    Problem solved, thank's
     

Share This Page