After 3.2 update Apache vhost files generated instead of nginx

Discussion in 'General' started by pilsetnieks, Nov 12, 2020.

Tags:
  1. pilsetnieks

    pilsetnieks New Member

    Hi,

    after an update from 3.1.6 to 3.2 ISPConfig seems to generate Apache vhost files instead of nginx ones after changes to websites but otherwise everything seems fine. The Resync tool also creates a bunch of new Apache vhost files. (Apache isn't even running on this server.)

    The settings in dbispconfig.server table still have webserver=nginx and server_type=nginx.

    Any ideas what could cause such a bizarre behavior?

    This is on Debian 10.6
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    That's quite a jump :)

    Did you reconfigure services? Was nginx configured? Do you have a custom vhost?
     
  3. ahrasis

    ahrasis Well-Known Member

    It's normally because you have apache2 installed or not removed wholly, and that's why perfect server tutorial ensures its removal when you are using nginx before downloading and installing ISPConfig.
     
  4. pilsetnieks

    pilsetnieks New Member

    Th0m, why is it a jump? 3.2 is literally the next version after 3.1.5 (I was mistaken about 3.1.6, sorry)

    ahrasis, right, that could be it, apache was installed, albeit disabled, at the time. After purging apache, ispconfig_update.sh does nothing (as it’s already the current version) but I downloaded the stable version and ran the update.php manually. That might have done some configuration changes, although ultimately what did it was deleting the symlink to apache plugin in
    /usr/local/ispconfig/server/plugins-enabled (which had appeared on the day when I did the ISPConfig upgrade.)

    Thanks for the pointer!
     
    ahrasis likes this.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The last version of the 3.1 series was 3.1.15p3, so you left out more than 10 intermediate versions when you updated from 3.1.5 to 3.2, so that's what Th0m pointed out. It's generally not a problem to do that though, your problem was just related to the apache install.
     
    Th0m likes this.
  6. pilsetnieks

    pilsetnieks New Member

    Right, no, sorry, that was just a typo, I upgraded from the previous version, there wasn't actually that much of a jump but somehow apache had snuck up on me.
     

Share This Page