admin panel https and http

Discussion in 'Installation/Configuration' started by Erjen, Aug 2, 2013.

  1. Erjen

    Erjen New Member

    Hi,

    Is it possible to make the admin panel run on HTTP and HTTPS? So that HTTPS will run on 8080 and HTTP on 8081 for example?

    This is my current ispconfig.vhost configuration:
    Code:
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin [email protected]
    
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
            MaxRequestLen 15728640
      </IfModule> 
    
     <IfModule mpm_itk_module>
        DocumentRoot /usr/local/ispconfig/interface/web/
            AssignUserId ispconfig ispconfig
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
     SSLEngine on
    SSLCertificateFile /var/www/clients/client3/web14/ssl/www.mydomain.nl.crt
    SSLCertificateKeyFile /var/www/clients/client3/web14/ssl/www.mydomain.nl.crt.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This is possible, but 8081 is already in use by the apps vhost, so better use 8082. Make a copy of the vhost file in the sites-available folder and replace all occurrences of 8080 by 8082. Then add a symlink in sites-enabled folder to that vhost file and restart apache. In the version without https, comment out all lines start start with SSL.
     
  3. Erjen

    Erjen New Member

    Thanks for your response!

    So this is the configuration from my new vhost:
    Code:
     Listen 8082
    NameVirtualHost *:8082
    
    <VirtualHost _default_:8082>
      ServerAdmin [email protected]
    
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
            MaxRequestLen 15728640
      </IfModule>
    
     <IfModule mpm_itk_module>
        DocumentRoot /usr/local/ispconfig/interface/web/
            AssignUserId ispconfig ispconfig
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
    # SSLEngine on
    #SSLCertificateFile /var/www/clients/client3/web14/ssl/www.mydomain.nl.crt
    #SSLCertificateKeyFile /var/www/clients/client3/web14/ssl/www.mydomain.nl.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    I created a symlink as you said, opened ports for 8082 in my router as always but it doesn't seem to work, no error, nothing.

    Is there anything else I should do?

    Thanks again!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The filelooks fine.Pleasecheck apache error.log for errors.
     
  5. Erjen

    Erjen New Member

    Very strange.. I can't find any errors in /var/log/apache2/error.log or in access.log. I also tried some other ports but the browser just keeps loading and then times out.
    I also tried the local ip [local ip:8082] which doesn't work but [local ip:8080] works fine as expected.

    Do you have any more ideas? Maybe there is another place to find some relevant log files?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    please post the output of:

    netstat -tap | grep apache
     
  7. Erjen

    Erjen New Member

    This is the output from that command:

    tcp6 0 0 [::]:http-alt [::]:* LISTEN 28444/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 28444/apache2
    tcp6 0 0 [::]:tproxy [::]:* LISTEN 28444/apache2
    tcp6 0 0 [::]:8082 [::]:* LISTEN 28444/apache2
    tcp6 0 0 [::]:https [::]:* LISTEN 28444/apache2
     
  8. Erjen

    Erjen New Member

    Solved :D! Very stupid, I didn't open the port on the server via admin panel..
    So everthing works fine now, thanks Till!
     

Share This Page