Admin login failed after upgrading to 3.0.5

Discussion in 'Installation/Configuration' started by jurrien, Feb 26, 2013.

  1. The-Ghost

    The-Ghost New Member

    PHP Version 5.3.22 on CentOs 5.9
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you build that PHP version yourself? Where is your php-cgi located? I guess it's in an uncommon location, and /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter is using the wrong (a nonexistant?) php-cgi.
     
  3. The-Ghost

    The-Ghost New Member

    The PHP version is comming with the yum update enablerepo=webtatic update php command

    /usr/bin/php-cgi
    /usr/local/ispconfig/server/conf/php-cgi-starter.master
    this I can locate
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Does /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter use /usr/bin/php-cgi?
     
  5. The-Ghost

    The-Ghost New Member

    his is what is in /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter

    #!/bin/sh
    PHPRC=/etc/
    export PHPRC
    export PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_CHILDREN=1
    exec /usr/lib/cgi-bin/php -d magic_quotes_gpc=off -d session.save_path=/usr/local/ispconfig/server/temp
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, so the 3.0.5.1 bugfix version is not installed on your server yet.

    Please execute these commands on your server:

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
  7. The-Ghost

    The-Ghost New Member

    admin login runs fine now.
    Thanx
     
  8. mkslim

    mkslim New Member

    500 internal server error

    I have tried everything listed in these threads and still cant load the admin interface. The other sites are working ok. I guess I should be asking how to restore the backup that was made prior to upgrade?
     
  9. jnewman67

    jnewman67 New Member

    tried these fixes as well, and they do not work for me either.

    Now when I try to restart apache, i get the following message:

    Code:
     service httpd restart
    Stopping httpd:                                            [FAILED]
    Starting httpd: [Sat Mar 23 15:23:51 2013] [warn] NameVirtualHost *:8080 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:8080
                                                               [  OK  ]
    
    it shows it started OK, but really it doesn't. The FAILED appears after having already restarted it once.

    I saw this after I updates the 000-ispconfig.vhost and the db_mysql_inc.php file manually, and reinstalling the stable version again did not fix it either.

    php version is php-5.3.3-22.el6.x86_64 on a CentOS 6.3 unit fully updated.

    Thoughts?
     

Share This Page