Additional PHP-FPM Version on Centos 7

Discussion in 'HOWTO-Related Questions' started by omniasoft, Sep 15, 2016.

  1. omniasoft

    omniasoft New Member

    I'm trying to add PHP 5.6,25 as an additional PHP Version in CEntos 7.1 and ISPConfig 3.1dev.
    I followed the guide:
    but at the end i've some problems:
    1) don't find some files for example cp /opt/php-5.6.25/etc/php-fpm.conf.default
    2) the sistem don't Start: /etc/init.d/php-5.6.25-fpm start (as there isn't star comand)
    now i've the php 7.0.7 and it not work with Magento :( so i trying to install additional PHP like 7.0.2 or 5.6.25

    Can you hel me ?
    thanks to all
  2. Thaddeus

    Thaddeus New Member HowtoForge Supporter

  3. omniasoft

    omniasoft New Member

    Thank you,
    now it work and i can se Php 7.0.11
    but the problem installing Magento it's the same:

    [ERROR] BadMethodCallException: Missing required argument $metadata of Magento\Framework\EntityManager\MetadataPool. in /var/www/clients/client1/web9/web/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php:45
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you check that ths magento version is really compatible with PHP 7.0.11? If this Magento version does not work with 7.0.7, then it will most likely not work with later versions like 7.0.11 as well.
  5. omniasoft

    omniasoft New Member

    hi Till,
    I solved the problem by itself.
    it was enough to simply delete the cache of the various browsers.
    Now the installed Magento (with the ISPConfig script) but I can not install the sample-data when i run the comand ./magento command ....:
    The openssl extension is required for SSL / TLS protection but is not available. If you can not enable the openssl extension, you can disable this error, at your own risk, by setting the 'disable-tls' option to true. # 0 / var / www / clients / client1 / web9 / web / vendor / composer /composer/src/Composer/Factory.php(306): Composer \ Factory :: createRemoteFilesystem (Object (Composer \ IO \ BufferIO), Object (Composer \ Config))
    # 1 /var/www/clients/client1/web9/web/vendor/composer/composer/src/Composer/Factory.php(532): Composer \ Factory-> createComposer (Object (Composer \ IO \ BufferIO), '/ var / www / client ... ', false)
  6. omniasoft

    omniasoft New Member

    i undestand that i need to install and activate OpenSSL
    and afeter install magento composer.
    But now i'he a PHp multi version under ISPConfig....
    how i can istall and activate OpenSSL?
    i tried under ssh (putty) on VPS centos but nothing...

Share This Page