Additional Hard Drive Installation Problem

Discussion in 'Installation/Configuration' started by msimpson7, Sep 2, 2006.

  1. msimpson7

    msimpson7 New Member

    Hello,

    I have been running Ubuntu 6.06 for a few months without problem. I decided to add a new hard drive for additional storage (250GB). It is a Western Digital IDE. The OS is on a Western Digital IDE 16 GB.

    After installed, the BIOS shows the new drive properly. Then when Ubuntu is starting, it shows the normal GUI and the normal startup messages. It gets to Starting the Root File System and then goes to the non-GUI screen stating it cannot find /dev/hdc1.

    If I disconnect the new drive, everything comes up OK. Since GRUB is running whether the new drive is connected or not, it seems to be connecting to the correct drive in the first place.

    Any help would be appreciated.

    Thank you.
     
  2. Ben

    Ben HowtoForge Supporter

    Can you either clean you /var/log/messages and reboot or copy the message content only from beginning of one boot sequence till the error appears?
     
  3. drks

    drks HowtoForge Supporter

    Um, please don't ever suggest to 'clean out a log file'.... unless it has filled the filesystem and you have to.


    It sounds like you probably have something already referencing '/dev/hdc1' in your /etc/fstab (maybe a CDROM?). Check out your '/etc/fstab' and comment out any line that is referencing '/dev/hdcX'. I would bet money on a misconfigured Jumper configuration, or that since you are adding a drive, you're moving the CDROM to '/dev/hdd'... so you will need to reconfigure the OS accordingly.

    The default is usually to have the CDROM listed in /etc/fstab, but with the 'noauto' option to keep it from mounting on bootup

    Maybe you can check the logs as suggested, something like:

    Code:
    cat /var/log/messages | grep "Aug 31" 
    
    or whatever the date is that you last booted. Also look at DMESG:

    Code:
    dmesg
    dmesg | grep -i 'hdc'
    

    Once you have the Drive connected, and booting up well... you then need to make sure that you have a filesystem, and then properly add that partition/mount point to '/etc/fstab':

    Code:
    fdisk /dev/hdc
    <create the partition table>
    
    mke2fs -j /dev/hdc1 
    (don't do this unless you are sure this is the blank/new partition - it will delete data)
    
    mkdir /mnt/drive2
    
    mount /dev/hdc1 /mnt/drive2
    
    Add the following to '/etc/fstab'
    
    /dev/hdc1    /mnt/drive2    ext3    defaults    1 2
    
     

Share This Page