Adding remote access to a MySQL database does nothing

Discussion in 'Installation/Configuration' started by simonb, Nov 3, 2012.

  1. simonb

    simonb New Member

    (ISPConfig Version: on Ubuntu 10.04)

    I need to make a MySQL database accessible to a remote server on the LAN. ISPConfig is running on

    I check the "Remote Access" checkbox and enter the IP of the remote server,, in the "Remote Access IP" textbox.

    I set the bind address in /etc/mysql/my.cnf
    bind-address            =
    I open port 3306 on the firewall for the remote server. Port 3306 appears open if I test it with nmap on the remote server. So far so good.

    However I can't access the database from the remote server.
    mysql -h c3songs -u c3songs -p 
    Enter password: 
    ERROR 1130 (HY000): Host '' is not allowed to connect to this MySQL server
    If I log into mysql as root on the ISPConfig server then there doesn't appear to be a c3songs user created for the address.

    mysql> select Host,User from mysql.user;
    | Host               | User             |
    |          | root             |
    | | root             |
    ...(abbreviated, other users listed here)
    | localhost          | c3songs          |
    ... (abbreviated, other users listed here)
    | localhost          | ispconfig        |
    | localhost          | root             |
    19 rows in set (0.00 sec)
    Is ISPConfig doing anything to enable remote access? I can't see any evidence of it in the database unless I am missing something.

    If I set the logging level to debug and run at the command line I see the following related output when I enable external dB access...

    03.11.2012-09:35 - DEBUG - Found 1 changes, starting update process.
    03.11.2012-09:35 - DEBUG - Calling function 'db_update' from plugin 'mysql_clientdb_plugin' raised by event 'database_update'.
    03.11.2012-09:35 - DEBUG - Changing MySQL remote access privileges for database: c3songs
    03.11.2012-09:35 - DEBUG - Processed datalog_id 254
    If I add permissions manually then I can access the database from the remote server. But shouldn't ISPConfig be doing that for me?

    This works...
    GRANT ALL PRIVILEGES ON c3songs.* To 'c3songs'@'' IDENTIFIED BY '*****';
    Last edited: Nov 3, 2012
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the mysql root password has been changed in mysql without changing it in ispconfig so that ispconfig is not able to alter the mysql user. Check that the mysql root password is correct in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf
  3. simonb

    simonb New Member

    Hi Till,

    I just checked the root password in the mysql_clientdb.conf with "mysql -u root -p" and it logged in fine. I haven't changed the mysql root password since installing ispconfig.


Share This Page