adding port 990 ftp to server

Discussion in 'HOWTO-Related Questions' started by kwickcut, Sep 24, 2011.

  1. kwickcut

    kwickcut Member

    Ubuntu 9.10 server with ISPConfig 3 with PureFTPd

    what i need to do is run a ftp server with ssl

    is there a how to for this and can there be an option under FTP-User in ispconfig for selection port 21 or 990?



    kwick
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. kwickcut

    kwickcut Member

    ok i have followed this setup and have added 990 to the firewall and in my router i pointed 900 to the server ip.

    but i am not able to connect to the server with port 990

    i am using flashfxp and i tried auth tls and implicit ssl and both usng port 990 can not make a connection.

    any ideas

    kwick
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to use FTPS on port 21? I'm not sure if port 990 is being used...
     
  5. kwickcut

    kwickcut Member

    yes i did and you can not log in

    i used this code
    Code:
    echo 1 > /etc/pure-ftpd/conf/TLS
    i have tried standard, auth ssl, auth tsl, and implictit ssl and can not log inwhen trying to use port 21 or 990 checked fire wall and they are both set to be open and can not log on at all

    the only way i could log in is if i ran this code
    Code:
    echo 0 > /etc/pure-ftpd/conf/TLS
    now i can log in as standard ftp and all the rest fail


    kwick
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Does it work if you completely disable the firewall (just for testing purposes)?
     
  7. kwickcut

    kwickcut Member

    i did not think to try that. i will look up the command and give it a try and post back thanks



    kwick
     
  8. kwickcut

    kwickcut Member

    ok i have disables the firewall using the command
    Code:
    sudo ufw disable
    then i tries to connect using tls and received the following output

    kwick
     
  9. falko

    falko Super Moderator ISPConfig Developer

    This looks like a problem in your FTP client. Can you try FileZilla instead?
     
  10. kwickcut

    kwickcut Member

    ok i was able to connect using filezilla well almost that is this is the output of the connection i am using ftp transfer protocol with required explicit ftp over tls on port 21
    Code:
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:	220-You are user number 3 of 50 allowed.
    Response:	220-Local time is now 15:31. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	AUTH TLS
    Response:	234 AUTH TLS OK.
    Status:	Initializing TLS...
    Status:	Verifying certificate...
    Command:	USER kwick1
    Status:	TLS/SSL connection established.
    Response:	331 User kwick1 OK. Password required
    Command:	PASS ********
    Response:	230-User kwick1 has group access to:  client#    sshusers  
    Response:	230 OK. Current restricted directory is /
    Command:	SYST
    Response:	215 UNIX Type: L8
    Command:	FEAT
    Response:	211-Extensions supported:
    Response:	 EPRT
    Response:	 IDLE
    Response:	 MDTM
    Response:	 SIZE
    Response:	 REST STREAM
    Response:	 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Response:	 MLSD
    Response:	 AUTH TLS
    Response:	 PBSZ
    Response:	 PROT
    Response:	 UTF8
    Response:	 ESTA
    Response:	 PASV
    Response:	 EPSV
    Response:	 SPSV
    Response:	 ESTP
    Response:	211 End.
    Command:	OPTS UTF8 ON
    Response:	200 OK, UTF-8 enabled
    Command:	PBSZ 0
    Response:	200 PBSZ=0
    Command:	PROT P
    Response:	200 Data protection level set to "private"
    Status:	Connected
    Status:	Retrieving directory listing...
    Command:	PWD
    Response:	257 "/" is your current location
    Command:	TYPE I
    Response:	200 TYPE is now 8-bit binary
    Command:	PASV
    Response:	227 Entering Passive Mode (192,168,1,111,140,195)
    Status:	Server sent passive reply with unroutable address. Using server address instead.
    Command:	MLSD
    Error:	Connection timed out
    Error:	Failed to retrieve directory listing
    it looks like it does not know what directory to open? this is what is set up under the user directory
    Code:
    /var/www/clients/client#/web#/web/ftp/
    now if i set filezilla to use plain ftp i get rite into the server with no troubles


    kwick
     
    Last edited: Sep 28, 2011
  11. falko

    falko Super Moderator ISPConfig Developer

    Can you try active mode as well?
     
  12. kwickcut

    kwickcut Member

    i have tried all modes the only one i can get into the directory with is normal ftp



    kwick
     
  13. kwickcut

    kwickcut Member

Share This Page