Adding or updating email users is not working

Discussion in 'ISPConfig 3 Priority Support' started by miguelpinheiro, May 4, 2020.

  1. Hi!
    Changing email account passwords or creating new ones stops me from logging in to email for that user (user/password invalid). It seeems the new accounts are not being updated/added to MySql.

    I'm running:
    ISPConfig Version: 3.1.15p3
    MariaDB Distrib 10.2.31
    Debian Jessie 8.

    Dovecot, Postfix, Amavis are all running.
    Last edited: May 4, 2020
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you test if the old password still works?
  3. I tested now and changing passwords now is working as expected. Strange but I can login (probably I was getting an issue with firewall).

    However, I'm still having problems with one specific domain not getting emails from external email addresses (like GMAIL or OUTLOOK). I can receive if sending from email addresses hosting in ISPConfig server.

    I tried creating new accounts with that domain and same result. I can log in to webmail, can send it through SMTP BUT it seems I can't receive any email. I disabled grey listing but the results are the same.

    All the domains except this one is failing. I tried resynch mail accounts in SPConfig panel but the result is the same. :(
    I'm a bit lost. Should I hire technical support?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to an account on that domain on webmail and send an email to the same address that you used for the webmail login. The email should arrive in the webmail inbox within a few seconds. If it does not arrive within a minute, take a look into the /var/log/mail.log file of your server and post the lines that got added there for the sending attempt at the end of the file.
  5. It arrived in just a few seconds. The problems seems to be when receiving from external email address (i.e. email addresses from domains NOT hosted in my ISPConfig server).
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that the mail system is ok and either the DNS records of these domains are wrong, the domains must have a DNS MX-Record which points to the server hostname or a subdomain that points to the server IP. And you must sure that the ISP or company that provides internet access to the server is not blocking port 25.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Or you blocked port 25 in the local firewall of the server or postfix is not listening on the external network interface. You should run the test script and post the results.
  8. Thanks till. It was the MX DNS record missing for that domain. It is now working just fine.

Share This Page