adding ftp access to a user at os level

Discussion in 'Installation/Configuration' started by dgmufasa, Dec 27, 2011.

  1. dgmufasa

    dgmufasa New Member

    Hello all,

    I have a user created with useradd but I cannot use ftp on it.

    Can someone point me to the way to create ftp access on a user created with "useradd"?

    These items (PHP code) were working with a FTP user created thru the interface:

    Now that I am using an ID created with useradd, it does not work (leading me to believe that there is something extra needed when creating users on an ISPConfig system outside the interface).

    Again, any suggestions are appreciated...

    Last edited: Dec 27, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You find the error messages for ftp in the linux syslog. See also aq on debugging ftp connectiond.
  3. dgmufasa

    dgmufasa New Member


    this is what I am getting

    I did some more tests and I get the following:
    This is not really helping as it does not seem to point to anything useful.
  4. dgmufasa

    dgmufasa New Member

    Hello again,

    Here is an ID created using the ISPConfig interface. In this case, the FTP works with BOTH sftp and regular ftp

    But when creating users using : useradd, this does not happen. Only the sftp works. not the regular ftp. To me, this would indicate that there is *something more* one must do in order to get the regular ftp to work. One cannot create the user using "useradd" and that be all.

    If you could share what that is, that would be ideal as I need to get this ID working and it is not possible to create this using the ISPConfig interface.
  5. dgmufasa

    dgmufasa New Member

  6. dgmufasa

    dgmufasa New Member

    Seems like I figured it out

    Basically, the link above gave me a hint.

    I created an FTP user thru the ISPConfig interface but following the hints that I saw above (I had to disable the automatic client [CLIENT] prefix to do it).

    So, it looks like things are ok - for now ...

Share This Page