Adding a custom port to Firewall record doesn't seem to work

Discussion in 'Installation/Configuration' started by Jigal van Hemert, Oct 26, 2017.

  1. Jigal van Hemert

    Jigal van Hemert New Member


    Ubuntu 16.03, ISPConfig 3.1.7p1, ufw as firewall.
    At first no configuration of the firewall had any effect. Suddenly the machine crashed and after reboot it didn't respond to http/ssh/whatever any more. With the console I could open some ports in ufw directly. I did notice that ufw and iptables showed a very different configuration.
    After that I managed to make ISPConfig control ufw with a trick I found in this forum (remove most ports in ISPConfig, disable ufw, re-add the original porst and enable ufw).
    Now the problem remains that adding custom ports has no effect. If I remove or re-add port 21 for example the configuration of ufw reflects the change (ufw status numbered). I need to add port 8983 which is the default port of Apache Solr. But adding it to the list in the Firewall record has completely no effect.
    What do I need to do to open this port?

    Thanks in advance for your effort.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Jigal van Hemert

    Jigal van Hemert New Member

    After running the script with debug level logging enabled the port was opened without a problem.
    Thanks for pointing to the debug mode!

Share This Page