Added record in ispconfig do not show in bind

Discussion in 'Installation/Configuration' started by kmchen, Oct 10, 2018.

  1. kmchen

    kmchen Member

    I add a A field in ispconfig3.1 > webologix.com > DNS Zone > Records, I see this (sorry I can't insert a screen capture of the ispconfig page) :
    But when I look in bind, even 1 hour later, I can't see any "pop" record defined:
    Code:
    [email protected]:/etc/postfix# cat /etc/bind/pri.webologix.com
    $TTL        600
    @       IN      SOA     ks392200.kimsufi.com. thierychen.yahoo.fr. (
                            2018042411       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            3600 )            ; minimum, seconds
    ;
    
    mail 3600 A        176.31.109.26
    ns1 600 A        176.31.109.26
    smtp 3600 A        176.31.109.26
    webologix.com. 600 A        176.31.109.26
    www 3600 A        176.31.109.26
    webologix.com. 3600      MX    10   mail.webologix.com.
    webologix.com. 600      NS        ks392200.kimsufi.com.
    default._domainkey.webologix.com. 3600      TXT        "v=DKIM1; t=s; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEArucYlp2rHXPGB3Xn0IjSIXSqixF9kkauZCqo30XIsGe5RShQnGDEUgfPZbHdw7O4wkfoobA6Lt3XBV6T9Zh8UGUNZcd//CgePZAWL4r6fkIvzlVHEhidDfQwaIAGMCZi/SI9TR+rlm2H7HJXlyeV1q5OfUnTO8NblFZ2QNuLhTxqusRQ3BVphkwBkXlyoUQgikj" "eNnStnwRNKsEqQ+Kmy4hYP3IrqV6odRAXcGGSqHNd82v/N+00gj2k1anr0MHUV0DVRHoQPcxVHB+x1/khoUsPRRdHCShNg5fsQMYbGryTTSRw3tJFKdCw7OaBS4W9mGRF+9FG2+wuaGKcdHscGQIDAQAB"
    ownercheck 3600      TXT        "3374414b"
    webologix.com. 3600      TXT        "v=spf1 mx a ~all"
    
    
    $INCLUDE Kwebologix.com.+007+13847.key
    
    $INCLUDE Kwebologix.com.+007+30810.key
    
     
  2. ahrasis

    ahrasis Well-Known Member

    Do check a copy of the file that ended with .err, if any, because if there is, it means that there may be some unacceptable errors in your zone file that prevent it from being rewritten properly.
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Try entering the A record with FQDN and a . at the end. Like this:
    Code:
    Yes A pop.webologix.com. 176.31.109.26 0 3600
     
  4. kmchen

    kmchen Member

    Hi, entering FQDN do not change anything but yes there is a pri.webologix.com.err but I can't see where is the error. Could it be the DKIM record ?
     
    Last edited: Oct 12, 2018
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  6. ahrasis

    ahrasis Well-Known Member

    Normally if you try to restar bind with the error file, it will complain its error and with the right settings, it will log it too.

    If you can share the .err file, somebody mayhelp to spot the error for you too.
     
  7. kmchen

    kmchen Member

    Code:
    [email protected]:/etc/bind# named-checkzone webologix.com /etc/bind/pri.webologix.com
    zone webologix.com/IN: loaded serial 2018042412
    OK
    [email protected]:/etc/bind# systemctl status bind9.service
    ● bind9.service - BIND Domain Name Server
       Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled)
       Active: active (running) since Fri 2018-10-12 10:27:58 UTC; 54min ago
         Docs: man:named(8)
      Process: 24951 ExecStop=/usr/sbin/rndc stop (code=exited, status=0/SUCCESS)
      Process: 10178 ExecReload=/usr/sbin/rndc reload (code=exited, status=0/SUCCESS)
     Main PID: 24961 (named)
        Tasks: 5 (limit: 4915)
       CGroup: /system.slice/bind9.service
               └─24961 /usr/sbin/named -f -u bind
    
    Oct 12 10:27:59 ns1 named[24961]: zone webologix.com/IN: loaded serial 2018042413 (DNSSEC signed
    Oct 12 10:27:59 ns1 named[24961]: zone mon-voyage-a-cuba.com/IN: loaded serial 2018101102 (DNSSE
    Oct 12 10:27:59 ns1 named[24961]: zone joomla-development.eu/IN: loaded serial 2018101011 (DNSSE
    Oct 12 10:27:59 ns1 named[24961]: zone localhost/IN: loaded serial 2
    Oct 12 10:27:59 ns1 named[24961]: all zones loaded
    Oct 12 10:27:59 ns1 named[24961]: running
    Oct 12 10:27:59 ns1 named[24961]: zone webologix.com/IN: sending notifies (serial 2018042413)
    Oct 12 10:27:59 ns1 named[24961]: zone joomla-development.eu/IN: sending notifies (serial 201810
    Oct 12 10:27:59 ns1 named[24961]: zone mon-voyage-a-cuba.com/IN: sending notifies (serial 201810
    Oct 12 10:27:59 ns1 named[24961]: zone les-meilleurs-films.net/IN: sending notifies (serial 2018
    And no error message when I restart bind :
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You tested the wrong zone file. The one which could not be loaded is the .err file. Use named-checkzone command to find out why BIND is rejecting to load the zone:

    named-checkzone webologix.com /etc/bind/pri.webologix.com.err
     

Share This Page