Add website - won't accept server input

Discussion in 'General' started by dailycompute, Jan 7, 2016.

  1. dailycompute

    dailycompute New Member

    When I try to add a website the add server field goes blank when I try to move to the next field.
    Discovered there was no web folder, added one and copied my site over to that folder. DNS is working via my provider so the site is publicly viewable.
    There is no info in the manual I bought to really help me solve the problem.
    Thinking about uninstalling ISPConfig 3 and starting again, but it there another way? I'm an ubuntu novice so I need muppet-proof instructions!!
    In System I have no servers showing, there's an empty horizonal fieldset that won't accept input.
    This is a simple single server setup (or it was supposed to be). As far as I can tell, everything else seems to work ok, although I can't access phpmyadmin either.
    Last edited: Jan 7, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The server field is s electbox (with search function), you cant enter a value there. If there is no value to select then your server is not installed correctly. Check that there is a server listed under System > Server services.

    That's not related to the first issue, phpmyadmin is inacessible when it is not enabled. I you use Ubuntu or Debian then you missed to select "Apeche" as decribed in the installation instructions during phpmyadmin installation, run:

    dpkg reconfigure phpmyadmin

    and select apache this time to enable it.

    use one of the perfect server guides that are listed here:

    They are used thousands of times a month, as long as you dont leave out a step you will always get a working setup.
  3. dailycompute

    dailycompute New Member

    Hi Till, Thanks for your reply. I followed the guide for Ubuntu 15.10 Wily Warewolf (forensically) and everything worked perfectly until my son deleted the server under Server> System Services (what a surprise!!, my fault I left the config window open...) There is no server listed now.
    Is there any way to repair this without un-installing everything and starting afresh?
    I'm certain I selected Apache when configuring phpmyadmin because I remember adding in the passwords during the config.
    Anyway, looks like I have to start again...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No need to reinstall the whole server, you just have to reinstall ispconfig. Run the following commands on the shell:

    sudo su
    cd /tmp
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q uninstall.php
    php -q update.php
    Just rerun the dpkg-reconfigure I posted above, it does not harm. The apt screen can be a bit tricky sometimes, selections are made with the [sppace] bar.

Share This Page