Add seccond ipadress to server

Discussion in 'Installation/Configuration' started by Nimarda, Sep 17, 2010.

  1. Nimarda

    Nimarda New Member


    I just added a seccond ipadress with ispconfig to the server.

    When i go to ispconfig websites, and select a website. I assign the new ipaddress to this website. And changed DNS A record for this website with the new ipaddress.

    But when viewing this website, i get a message Server not found.. Even changed my local hostfile to this ipaddress.

    Do i have to do anything else to get this working?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you configured the IP also in the network card configuration file of the linux distribution.
  3. Nimarda

    Nimarda New Member

    Hi Till,

    Thanks for your reply!

    How do i configure this? I found something like this:
    auto eth0 lo
    iface eth0 inet static
    iface lo inet loopback
    My seccond IP address wil be:
    How can i add this?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    To add an additional IP, add lines like this at the end of the file:

    auto eth0:0
    iface eth0:0 inet static
    If you want to add more IP's, the virtual interface names are eth0:0, eth0:1, eth0:2, eth0:3 etc.
  5. Nimarda

    Nimarda New Member

    Okay thats worked!!

    But now i have a problem. Can i only assign one website to this ipaddress?

    Because when i assign a website to this new ipaddress, and added a seccond website to this address. And when i visit this new websites, i get every time the same site.

    so for example: has new ip has new ip

    when i visit i get the website
    and is
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can assign as many websites to a IP as you want. Just make sure that every website has the correct IP assigned in the website settings and in DNS and that you selected auto subdomain www in every website if you want to be able to access the website also with www.domain.tld and not jsut domain.tld.
  7. Nimarda

    Nimarda New Member

    Ah okay that was my problem.. Didnt check auto www.

    Thanks! and all my problems solved ;)

Share This Page