Add Ports to Fireall

Discussion in 'General' started by Quaxth, Jan 29, 2014.

  1. Quaxth

    Quaxth New Member

    Before getting problems again, I would like to know if I just could edit the existing Firewall record and add the new needed Ports directly to that record.

    I ask, because that was trigger the problem of deleting the Server Record a few weeks back!

    If I like to add a new Firewall record, that will not works and I get the error messages that already an Record exist for this server.

    I now have:
    1. a Clonezilla Image of the whole server
    2. a Backup of the Server as .TAR file
    so, this time I would be able to get either the server records back or restore the server from the Clonezilla Image.

    Thanks for any answer.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The firewall record represents your firewall, you can have only one firewall on a server, thats why you cant add another one.

    To open up a port in the firewall, click on edit, add the port in the ports list of the firewall and then click on save.
     
  3. Quaxth

    Quaxth New Member

    Except that's different Ports I need to add, otherwise is the same procedure I was using as the Server records were disappearing which forced me to a new setup of the whole server! Because the actions you suggested were not working!

    That's why I ask that could happen again?! Even now I use Debian 7.1 instead of the older 7.1 and it's a new installation of ISPConfig etc.!

    So, just edit and saving should do the job correctly?

    Thanks.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I told you already the the issue that you had the last time was not caused by editing the firewall record. it was caused by a click on the delete icon in the server services or server config list. I know that you dont remember that, but its a fact that you can read yourself in the sourcecode that its impossible to delete a server record by editing the firewall.

    And just for statistical reasons, if server records would disappear when you just edit the firewall, then you should find a few hundred or even more threads about that issue here in the forum, as there are several hundred thousand servers worldwide that use ispconfig.
     
  5. Quaxth

    Quaxth New Member

    The only things I'd done at the old server were to install WaveMaker and than added the required ports to the Firewall using the edit function and saved after added those Ports! Period!

    No any deletion were done! Period!

    After checked I could start WaveMaker and was get an error, I opened ISPConfig as admin again and that was the point were the Server Record were gone. E-mail was working, normal websites was working but ISPConfig!

    Afterwards I posted on the forum and done exactly as you told and things got more worst! Now the E-mail wasn't work any more, access to the websites, except one was gone as well!

    As I wasn't get anything what helped, I had no choice as re-install completely from Zero which I did!

    Now I didn't installed WaveMaker (yet, will be done later again) and the Ports I need to add are for Idera Backup Server because I want now the normal backup running on server for to have everything backed up and be on the safe site!

    Also, I'll make after successfully installing any new apps a new Image using Clonezilla which give me the ability for to restore the server to the last working stage with no problems. Idera Backup Server will be used for schedules backups in 2 different ways, firstly full backup every week and secondly min. daily backups of new and changed data.

    And again, you should believe me if I tell you that I didn't deleted anything, added just 3 new ports to the firewall after I installed WaveMaker at the old server. What were trigger that problem of the "missing" Server Record, I don't know, it wasn't I! Period!

    Regards and Thanks.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I believe you that you havent intentionally deleted the server record. I just pointed out that it can not have been deleted by the code that edits the firewall record and that the circumsatnces that caused the issue are so special that no other users servers of a very large userbase are affected. So it must have been something else e.g. a harddisk corruption which affected the database table file of the mysql database.
     

Share This Page