add php7.3 and now error 500

Discussion in 'Server Operation' started by ewkilian, Mar 27, 2020.

  1. ewkilian

    ewkilian Member

    Hi,
    I have install PHP7.3 on my server at the origin with 7.0.
    But now when I want go on the panel : https://myIP:8080 I have a error 500.
    How can I execute ISPCONFIG With PHP 7.0 ?
    Code:
    Mydomaine.com:8080 62.102.228.*** - - [27/Mar/2020:16:24:27 +0100] "GET / HTTP/1.1" 500 579 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0"
    Mydomaine.com:8080 62.102.228.*** - - [27/Mar/2020:16:24:27 +0100] "GET /favicon.ico HTTP/1.1" 200 19065 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0"
    Or How can I found the solution to not have this error ?
    thank you very much
    (sorry my english is bad)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which operating system?
     
  3. ewkilian

    ewkilian Member

    OS Debian 9

    It's ok. i have see:
    https://tecadmin.net/switch-between-multiple-php-version-on-debian/
    But now I see that :
    Code:
    [email protected]:/etc/apache2/mods-available# update-alternatives --config php-cgi
    There are 2 choices for the alternative php-cgi (providing /usr/bin/php-cgi).
    
      Selection    Path                 Priority   Status
    ------------------------------------------------------------
    * 0            /usr/bin/php-cgi7.3   73        auto mode
      1            /usr/bin/php-cgi7.0   70        manual mode
      2            /usr/bin/php-cgi7.3   73        manual mode
    
    Can I change that PHP 7.0 in auto mod ?
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  5. ewkilian

    ewkilian Member

    Thank you for your help :) :)
     

Share This Page