Add-on websites not sending zone/NS records

Discussion in 'Installation/Configuration' started by dskerror, Dec 25, 2013.

  1. dskerror

    dskerror New Member

    Hello all, thank you ISPconfig for a great web hosting platform.

    I recently got ISPconfig 3 configured properly onto a Centos 6.5 virtual machine behind a reverse proxy with all the necessary ports opened from the router.

    I have added a vanity nameserver and the domain resolves without issue. However, when attempting to add another domain, the NS zone records do not resolve!

    The main domain resolves, but any add-on domains do not show any zone or NS records... do I have to add records to the NS domain on my server or something?

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.
    ##### ISPCONFIG #####
    ISPConfig version is
    ##### VERSION CHECK #####
    [INFO] php (cli) version is 5.3.3
    ##### PORT CHECK #####
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    ##### MAIL SERVER CHECK #####
    [WARN] I found no "submission" entry in your postfix
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.
    [INFO] I found the following web server(s):
            Unknown process (httpd) (PID 6030)
    [INFO] I found the following mail server(s):
            Postfix (PID 1521)
    [INFO] I found the following pop3 server(s):
            Dovecot (PID 1422)
    [INFO] I found the following imap server(s):
            Dovecot (PID 1422)
    [INFO] I found the following ftp server(s):
            PureFTP (PID 1572)
    ##### LISTENING PORTS #####
    (only           ()
    Local           (Address)
    [anywhere]:110          (1422/dovecot)
    [anywhere]:143          (1422/dovecot)
    [anywhere]:111          (1059/rpcbind)
    [anywhere]:21           (1572/pure-ftpd)
    ***.***.***.***:53              (1038/named)
    [localhost]:53          (1038/named)
    [anywhere]:22           (1256/sshd)
    [localhost]:631         (1134/cupsd)
    [anywhere]:25           (1521/master)
    [localhost]:953         (1038/named)
    [anywhere]:38588                (1077/rpc.statd)
    [anywhere]:993          (1422/dovecot)
    [anywhere]:995          (1422/dovecot)
    [localhost]:10024               (1445/amavisd)
    [localhost]:10025               (1521/master)
    [anywhere]:3306         (1392/mysqld)
    [localhost]10           (1422/dovecot)
    [localhost]43           (1422/dovecot)
    [localhost]11           (1059/rpcbind)
    *:*:*:*::*:8080         (6030/httpd)
    *:*:*:*::*:80           (6030/httpd)
    *:*:*:*::*:8081         (6030/httpd)
    *:*:*:*::*:21           (1572/pure-ftpd)
    *:*:*:*::*:58293                (1077/rpc.statd)
    *:*:*:*::*:53           (1038/named)
    *:*:*:*::*:22           (1256/sshd)
    *:*:*:*::*:631          (1134/cupsd)
    *:*:*:*::*:25           (1521/master)
    *:*:*:*::*:953          (1038/named)
    *:*:*:*::*:443          (6030/httpd)
    *:*:*:*::*:993          (1422/dovecot)
    *:*:*:*::*:995          (1422/dovecot)
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    fail2ban-SSH  tcp  --  [anywhere]/0            [anywhere]/0           tcp dpt:22
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain fail2ban-SSH (1 references)
    target     prot opt source               destination
    RETURN     all  --  [anywhere]/0            [anywhere]/0
  2. Quaxth

    Quaxth Member

    If you use to have the server run ning at your office or at home, you'll need for each NS (NameServer) it's own static public IP. If your server is somewhere in an Data Center, they should provide you with at minimum 2 different NameServer IP's.

    If you run from your location and have 1 static public IP only, use the NameServer of your ISP which would be provided free of charge. In that case, don't use any DNS Zones in ISPConfig, if you have, delete them. You'll need to all needed Records (A Record and others) via your ISP.
  3. dskerror

    dskerror New Member

    Hi Quaxth, I have a single static IP and I am using ISPConfig as a nameserver. The problem is that the zone files for the add-on websites for some reason does not send NS records.
  4. Quaxth

    Quaxth Member

    AFAIK you could not use ISPConfig for namerservers because you have only 1 IP!! I had the same problem, which I solved for to use my Registras Nameservers.

    And sorry, in my post I wrote to use the ISP's Namesers and that was wrong. You need to use the Nameserver from your Registra (where you registered your Domainname). I use, other may use GoDaddy or others. That registra has Nameservers provided free to the registrants (you). Also you create the needed Records at your Registra. I just use A Records for any Domain and that works fine. In ISPConfig I didn't have an single DNS Zone set!

    For any Website/Domain, you need at least 2 Nameservers and that means: at least 2 static/public IP's as well! Each Nameserver need his own static/public IP!
  5. Quaxth

    Quaxth Member

    Use intoDNS

    I would suggest that you check with:

    Open that Website, key in your domainname and click Report which will result in an report about all settings regarding that domain and show tehy're correct or not!
  6. dskerror

    dskerror New Member

    I used intoDNS all the time, but here is a little more information that I posted on another forums:

    I have one static public IP address, and have the registrar with the glue records/domain all configured properly. I have registered both NS1 and NS2 to the registrar.

    All NAT has been configured with ports 21, 53, 80, 443, opened and ready.

    The first domain ( was created with A records for NS1 and NS2. (, I have plans to add additional websites to this server using,

    When I add additional websites, I create the appropriate DNS records for them:

    A public.ip.address 0 3600
    A mail public.ip.address 0 3600
    A www public.ip.address 0 3600
    MX 10 3600
    NS 0 3600
    NS 0 86400

    Using IntoDNS for my add-on domain I get the following errors:
    Mismatched NS records WARNING: One or more of your nameservers did not return any of your NS records. Error DNS servers responded ERROR: One or more of your nameservers did not respond: The ones that did not respond are: 111.222.333.444

    My primary domain on the server ( functions without any issues.
  7. Quaxth

    Quaxth Member

    You wrote that you had set DNS Zones in ISPConfig! Or am I wrong?
    If you set any DNS Zones or Nameserver to or in ISPConfig: DELETE them!

    Without an extra static/public IP you could NOT use an ISPConfig Nameserver! That will trigger problems!
  8. dskerror

    dskerror New Member

    Okay, I have deleted the zones.. But then this means I can only host one website on a single IP address?

    My primary domain is working just find and can be accessible from WAN...
  9. Quaxth

    Quaxth Member

    You just create A Records at the registra where that other Websites/Domains are registered.

    If you use that other websites on the same domain what you use right now, you just need to create the related Records on that registra. You not told how many domains you've registered! But that shouldn't be any problem.

    I use several domain on my server with just 1 static/public IP and that are a mix of paid Domains as well as Free .TK domains. There isn't any problem for me. ALL domains have their own A Record pointing to my IP. Works fine!
  10. dskerror

    dskerror New Member

    Thank you again Quaxth, would it be possible for me to PM you for a little guidance? I want to accomplish using either vanity or physical nameservers, and believe I am close to getting it done right.
  11. Quaxth

    Quaxth Member

    Forum are for to get help and help other members. Using PM's for that is not really in line with that! As long as there didn't get personal and/or confidential data involved, I wouldn't like to use the private messaging system for that.

    And what's the problem for no to ask your question on the public forum? Also it's possible that some of my answer will contains some error (as did already in the one post of mine!), which could be clarified by other members. I'm quite new for this system and special Linux as well.

    OK, I'm in the computer business but hadn't used Linux at all till 3 month ago! I'm mainly using Windows based system and AS400 Mainframe, both on medium and large Networks. But Hosting!!

    So, if I could help on forum, I'll do, just ask your questions and I'll try to answer as good as possible. Let other profit from it as well, that's what this kind of forums all about! Also, please realize my local time, I'm in Thailand, means GMT/UTC +7h!

Share This Page