Add new website: folders OK but still "shared IP" notice

Discussion in 'Installation/Configuration' started by djkoelkast, Jul 2, 2007.

  1. djkoelkast

    djkoelkast New Member

    I reinstalled Debian 4.0 through the perfect setup yesterday, everything was fine, added about 26 websites, all fine.
    But when I add another website now as admin but for one of my reseller accounts it does make the domain, it does make the /var/www/webXX/ folder but it still gives a shared IP when I type in the address, even after uploading files.

    The site does *not* appear in /etc/apache2/vhosts/Vhosts_ispconfig.conf nor in one of the backup files. But before (the other 26 sites) it did...

    This also appears when I add the site under Admin (just tested it).

    When I restart Apache I get this:

    Code:
    server:~# /etc/init.d/apache2 restart
    Forcing reload of web server (apache2)...[Mon Jul 02 16:22:06 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
    [Mon Jul 02 16:22:16 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
    .
    server:~#
    
    I already tried to comment out some of the virtual host things as in one of the howtos here on the site but it didn't help.
    And now I cannot add any sites, or I have to manually edit the /etc/apache2/vhosts/Vhosts_ispconfig.conf-file every time...

    Anybody any suggestions on this?

    Thanks
     
  2. Hans

    Hans Moderator

    Do you have the line:

    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf

    At the very end within your apache2 configuration file which is /etc/apache2/apache2.conf ?
     
  3. djkoelkast

    djkoelkast New Member

    yes, the last line is (copy/paste from the actual file):

    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
     
  4. djkoelkast

    djkoelkast New Member

    I found out that everytime I make a new domain it will make a new file, like:

    Vhosts_ispconfig.conf_02-07-07_22-02-29
    Vhosts_ispconfig.conf_02-07-07_22-02-16
    Vhosts_ispconfig.conf_02-07-07_22-02-02
    Vhosts_ispconfig.conf_02-07-07_21-50-15

    etc. and these do contain the updated versions!
    I renamed the last one to Vhosts_ispconfig.conf and it does work, though the error is still there... (the [warn] thing)
     
  5. till

    till Super Moderator

  6. djkoelkast

    djkoelkast New Member

    ok but I don't see a solution for my problem? I did rename it but next time it will give a new file with a new date again...

    httpd -t gives:

    Code:
    server:~# httpd -t
    [Tue Jul 03 10:16:29 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
    Syntax OK
    
     
  7. Hans

    Hans Moderator

    Is the IP-address 192.168.1.75 also mentioned within your file /etc/network/interfaces and within ISPConfig under Management > Server > Settings?
     
  8. djkoelkast

    djkoelkast New Member

    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    # allow-hotplug eth1
    auto eth1
    iface eth1 inet static
    address 192.168.1.75
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.50
    
    eth0 is the onboard 10/100 which I don't use, I do use eth1 which is a 1000mbit card.

    It is also mentioned under management > server under IP address
     
  9. falko

    falko Super Moderator

    I hope your file looks rather like this:

    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    # allow-hotplug eth1
    auto eth1
    iface eth1 inet static
        address 192.168.1.75
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.50
    The leading spaces are important - they mean that the address, netmask, etc. settings still belong to eth1.
     
  10. djkoelkast

    djkoelkast New Member

    actually no, the file was 1 on 1 copy/paste, there are no leading spaces or a tab, so I should add them I guess

    Strange thing still is that the first 26 domains gave no problem ;)

    Should I add some spaces or 1 tab before the lines?
     
  11. Hans

    Hans Moderator

    You can use the tab, or use the spacebar as well.
     
  12. djkoelkast

    djkoelkast New Member

    I did (see edited post) but it doesn't solve anything unfortunatly
     
  13. Hans

    Hans Moderator

    Is ISPConfig writing a new vhost-file, if you change an item on the Basis-tab within the ISPConfig Manager or not?
     
  14. djkoelkast

    djkoelkast New Member

    Latest file now: Vhosts_ispconfig.conf_03-07-07_09-33-25

    Changed a site to enable CGI and changed the traffic MB by a little, saved it
    and the latest file is now:

    Vhosts_ispconfig.conf_03-07-07_16-18-40

    So yes it does, first file was 69.096 in size, the new one 69.196 (which should be ok as I enabled CGI)

    the Vhosts_ispconfig.conf remains unchanged...
     
  15. falko

    falko Super Moderator

    Please rename Vhosts_ispconfig.conf_03-07-07_16-18-40 to Vhosts_ispconfig.conf (back up the old one) and run
    Code:
    httpd -t
    What's the output?
     
  16. djkoelkast

    djkoelkast New Member

    Code:
    server:~# httpd -t
    [Wed Jul 04 15:15:29 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
    Syntax OK
    server:~#
    
     
  17. falko

    falko Super Moderator

    Hm... Can you post the output of
    Code:
    httpd -t
    echo $?
    ?
     
  18. djkoelkast

    djkoelkast New Member

    Code:
    server:~# httpd -t
    [Wed Jul 04 15:35:50 2007] [warn] NameVirtualHost 192.168.1.75:80 has no VirtualHosts
    Syntax OK
    server:~# echo $?
    0
    server:~#
    
     
  19. falko

    falko Super Moderator

    Hm, looks ok. And you really renamed Vhosts_ispconfig.conf_03-07-07_16-18-40 to Vhosts_ispconfig.conf before?

    Any errors in /home/admispconfig/ispconfig/ispconfig.log? What's the output of
    Code:
    ls -la /root/ispconfig
    ?
     
  20. djkoelkast

    djkoelkast New Member

    I rename the last one to Vhosts_ispconfig.conf everytime because otherwise it won't do anything with my changes.

    There are some WARN lines in ispconfig.log:

    Code:
    03.07.2007 - 20:42:19 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2418: WARNING: could not httpd -t  &> /dev/null
    03.07.2007 - 20:42:19 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2429: httpd syntax seems to contain errors, reloading with old configuration
    
    03.07.2007 - 20:49:42 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2418: WARNING: could not httpd -t  &> /dev/null
    03.07.2007 - 20:49:42 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2429: httpd syntax seems to contain errors, reloading with old configuration
    
    As they are all the same I won't post them all

    Code:
    server:~# ls -la /root/ispconfig
    total 100
    drwxr-xr-x  9 root root  4096 2007-07-04 18:48 .
    drwxr-xr-x  9 root root  4096 2007-07-01 16:09 ..
    -rwxr-xr-x  1 root root 34866 2007-07-01 16:10 cronolog
    -rwxr-xr-x  1 root root  9673 2007-07-01 16:10 cronosplit
    drwxr-xr-x 12 root root  4096 2007-07-01 15:55 httpd
    drwxr-xr-x 15 root root  4096 2007-07-01 16:10 isp
    -rw-r--r--  1 root root     8 2007-07-04 18:48 .old_path_httpd_root
    drwxr-xr-x  6 root root  4096 2007-07-01 15:53 openssl
    drwxr-xr-x  6 root root  4096 2007-07-01 16:09 php
    drwxr-xr-x  4 root root  4096 2007-07-01 16:10 scripts
    drwxr-xr-x  4 root root  4096 2007-07-01 16:10 standard_cgis
    drwxr-xr-x  2 root root  4096 2007-07-01 16:10 sv
    -rwx------  1 root root  9389 2007-07-01 16:10 uninstall
    server:~#
    
     

Share This Page