add new site not working

Discussion in 'Installation/Configuration' started by ashy_larry, Jan 12, 2011.

  1. ashy_larry

    ashy_larry New Member

    hey guys, newb here. i tried searching, but couldnt find an answer.

    fresh installs of ubuntu 10.04 lamp and ispconfig 3

    the clients folder is missing from /var/www and whenever adding a new site within ispconfig3 folders are not being added in that directory?

    i have premissions set on /www to 777.

    any ideas?
     
  2. till

    till Super Moderator

    Thats not good. Please undo that and restore the permissions that you had before or the system may fail.

    To your original problem, which tutorial did you use to install your server?
     
  3. ashy_larry

    ashy_larry New Member

    sorry it was set to 755 is that correct? i used the ubuntu 10.04 perfect server ispconfig3.
     
  4. till

    till Super Moderator

    755 should be ok.

    ok.

    Please login to ispconfig, go to the monitor and check if there are any jobs listed in the jobqueue. Additionally check the system log in the monitor for errors.
     
  5. ashy_larry

    ashy_larry New Member

    lots of jobs in the jobsqueue where i tried to test deleting and adding sites. system-log is empty.
     
  6. till

    till Super Moderator

    Please enable loglevel debug under system > server config and then run this command as root on the shell:

    /usr/local/ispconfig/server/server.sh
     
  7. ashy_larry

    ashy_larry New Member

    ok done. do i need to post the whole thing or am i looking for something specific?
     
  8. till

    till Super Moderator

    Are there any lines marked as error or are there only debug messages?

    Have the sites been created now?
     
  9. ashy_larry

    ashy_larry New Member

    yes it put them in now! however if i add a new site now it doesnt work unless i do the root command again.
     
  10. till

    till Super Moderator

    Then you have a problem with cron. Cron is normally installed by default in Ubuntu, but your server seems to have no cron daemon installed. You can install it with:

    apt-get install cron
     
  11. ashy_larry

    ashy_larry New Member

    ok just installed cron, but it would not add the folders again with out the command below.

    /usr/local/ispconfig/server/server.sh
     
  12. till

    till Super Moderator

    Cron will call the server.sh command once a minute. You have just to wait a minute until they get created.
     

Share This Page