Add DNS, start Mydns problems.

Discussion in 'General' started by perezz, Jul 3, 2009.

  1. perezz

    perezz New Member

    Hi,

    i've installed ISPconfig on Fedora 10.kernel 2.6.27.
    First time (3 days) everything is fine.
    But there are some things i cant resolve yet.

    2. This problem exist from the begining. After reboot, mydns-mysql can't start. I have to stop mydns then start mydns-mysql.
    In ISPconfig monitor there is an error that mydns server is not started. but in fact it works.

    3. I added about 10 sites. My server hostname ns.domain.ru.
    When i try to enter it through my browser, it shows the page of the last site i added.
     
    Last edited: Jul 3, 2009
  2. till

    till Super Moderator

    2) Make sure that mydns starts afetr the mysql server.
    3)Mkae sure that the sites point bto the correct IP and that you added every site as a separate website and not subdomain as subdomians are aliases that point to the same website were you added them.
     
  3. perezz

    perezz New Member

    1. I rebuild MyDNS from src, then added 20sec delay to MyDNS daemon.
    (Mysql daemon starts too long)
    Problem solved.

    2. Problem solved, thanks.




    3. In system monitor shows that mydns service is down.
    As i understand, the problem exist because of rebuilded mydns (binary and pid files are at the different way than it is an ispconfig).
    True?
     
  4. till

    till Super Moderator

    3) No, thats not the case. ISPConfig checks for the tcp port and not a pid file. You will have to wait aome time as the status monitor is only updated every 5 minutes.
     

Share This Page