Add 2nd website to ISPConfig3

Discussion in 'Installation/Configuration' started by courriercasa, Jun 7, 2011.

  1. courriercasa

    courriercasa New Member


    First excuse my english

    I have 2 domains : and
    Dedicate server
    ISPConfig 3

    I configured the domain and everything works perfectly.

    so I took a second domain, and I added it via ISPConfig and configured the dns ...

    once done, I reboot apache and mydns, and when I try to access the site it brings me directly to the directory reserved.

    If I delete the domain ispconfig3 life, the working again normally.

    What should I do to remedy this problem
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you added both domains as websites and not as subdomain or aliasdomain. Then check the dns settings for both domains and make sure that you selected either * or the IP address in the website settings for all websites on that server, do not mix * and IP!
  3. courriercasa

    courriercasa New Member

    Thank you for The replat.

    Yes i aèdes all The websites as websites and not and not subdomains.

    In The dns i choosed ip address for both site.

    The problèm is not fixed :-(

    Thanks for helping me
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the ip settings under system > server IP and ensure that the "Namevirtualhost" Checkbox is enabled.
  5. courriercasa

    courriercasa New Member

    Yes NameVirtualHost is already Enabled
  6. courriercasa

    courriercasa New Member

    In the website setting page, when I set the same ip address for both of the sites, no one of the work.

    So I set ip address for the first one and (*) for the second. work fine but redirect me to

    I have just one ip address and two domains

    Thanks all
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This can not work and will produce the behaviour that you described. NEVER use IP and * mixed on a server, as apache will redirect all connections to the site where the IP is selcetd then.

    Please select the IP address for both sites or * for both sites but dont mix them.

    This does not matter. You can run as many websites on one IP address as you like.
  8. courriercasa

    courriercasa New Member


    If i set ip address or (*) for both sites, I got the same problem described in the first post :(

    Is there something that I have to do in the apache configuration to fix that problem ?

  9. courriercasa

    courriercasa New Member

    Now i tried to set IP address for both websites and I got the following message :

    Not Found

    The requested URL /send/index.php was not found on this server.

    Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g Server at xx.xx.xx.xx Port 80

    I did the something with (*) for both sites and I got the same message
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you select auto subdomain www in the website settings?
  11. courriercasa

    courriercasa New Member

    Yes I did for both domains

Share This Page