Activation of cgi-bin

Discussion in 'Installation/Configuration' started by misterm, Sep 14, 2005.

  1. misterm

    misterm HowtoForge Supporter

    Hello

    I have a problem with repertory cgi-bin, when I give permissions on files * pl or * cgi, it give me like error "Error 500 - Error of the waiter!".

    Whereas I do have to make, to change the address in the file conf of ispconfig?

    Yours sincerely

    MM :confused:
     
  2. web-worlds

    web-worlds New Member

    Me too

    Hi,

    I also run into trouble with the CGI-BIN i uploaded a shoutbox script in ASCII and I set permissin on the install file to 755, but when I try to call the install file (http://www.domain.tld/cgi-bin/install.py) I get a 500 error - Internal Server Error!

    What am I missing here ??

    Kind regards,
    Etienne van Bruggen

    ps I run Suse Linux 9.2 server with a perfect setup of ISPconfig
     
  3. edge

    edge HowtoForge Supporter

    Is the "#!/usr/bin/perl" at the top of the script set to the correct path?
     
  4. sjau

    sjau Local Meanie

    check apache logs - what do you get there when you call the script?
     
  5. web-worlds

    web-worlds New Member

    the first line in the script is:

    #!/usr/bin/python

    I understand that this should be changed, but to what?

    And about the log, I will get back to that in a second...

    Thnaks in advance,
    Etienne
     
  6. falko

    falko Super Moderator

    If it's a Python script, then this should work (make sure /usr/bin/python exists).
    Did you enable suExec on your server?
     

Share This Page