activate php socket -> 500 error

Discussion in 'ISPConfig 3 Priority Support' started by chico11mbit, Mar 13, 2021.

  1. chico11mbit

    chico11mbit Member HowtoForge Supporter

    Hello,

    When enabling

    Use socket for PHP-FPM

    I get the yellow page on the website with "Error 500 - Internal server error".

    All other domains are running normally.

    Without activation everything runs normally.


    error message is in the error.log:
    AH01144: No protocol handler was valid for the URL /index.php. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.

    What can I do?

    best regards

    system:
    ubuntu 14.04LTS
    is-config 3.15p3
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Check the path where sockets are stored in php settings, and ensure that exists or change it.

    If that doesn't resolve it, enable server debugging then change that setting and run server.sh manually and post the output.
     
  3. chico11mbit

    chico11mbit Member HowtoForge Supporter

    in /opt/php72/etc/php-fpm.d/web19.conf

    listen = /var/lib/php5-fpm/web19.sock
    listen.owner = web19
    listen.group = www-data
    listen.mode = 0660


    /var/lib/php5-fpm/web19.sock exists


    output from server.sh

    13.03.2021-18:22 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    13.03.2021-18:22 - DEBUG - Found 1 changes, starting update process.
    13.03.2021-18:22 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    13.03.2021-18:22 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    13.03.2021-18:22 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client1/web19' - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client1/web19' - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: df -T '/var/www/clients/client1/web19'|awk 'END{print $2,$NF}' - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: which 'setquota' 2> /dev/null - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: setquota -u 'web19' '11264000' '11265024' 0 0 -a &> /dev/null - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: setquota -T -u 'web19' 604800 604800 -a &> /dev/null - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client1/web19' - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: which 'apache2ctl' 2> /dev/null - return code: 0
    13.03.2021-18:22 - DEBUG - safe_exec cmd: which 'apache2ctl' 2> /dev/null - return code: 0
    13.03.2021-18:22 - DEBUG - Add server alias: xxx.de
    13.03.2021-18:22 - DEBUG - Enable SSL for: yyy.de
    13.03.2021-18:22 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/yyy.de.vhost
    13.03.2021-18:22 - DEBUG - safe_exec cmd: which 'apache2ctl' 2> /dev/null - return code: 0
    13.03.2021-18:22 - DEBUG - Writing the PHP-FPM config file: /opt/php72/etc/php-fpm.d/web19.conf
    13.03.2021-18:22 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    13.03.2021-18:22 - DEBUG - Restarting php-fpm: service php72-fpm reload
    13.03.2021-18:22 - DEBUG - Apache status is: running
    13.03.2021-18:22 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    13.03.2021-18:23 - DEBUG - Restarting httpd: service apache2 restart
    13.03.2021-18:23 - DEBUG - Apache restart return value is: 0
    13.03.2021-18:23 - DEBUG - Apache online status after restart is: running
    13.03.2021-18:23 - DEBUG - Processed datalog_id 16775
    13.03.2021-18:23 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
     
    Last edited: Mar 13, 2021
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have a typo in the service name? Should be php7.2-fpm?
     
  5. chico11mbit

    chico11mbit Member HowtoForge Supporter

    nope. it is called 72. the whole folder ist called php72 and it is running flawlessly without sock
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ubuntu 14.04 is really old, might be an incompatibility of the old web server software with the custom compiled PHP 7.2 that is causing this.
     
  7. chico11mbit

    chico11mbit Member HowtoForge Supporter

    nope. same behavior with all other optional installed php versions like 5.6
     
  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    ISPConfig 3.1.15p3 does not support Ubuntu 14.04 - and from 3.2 and up only 18.04 and newer is supported

    Ubuntu 14.04 does not receive support anymore: https://help.ubuntu.com/community/EOL
    Also, we fixed several security issues in 3.2 and above.

    I would strongly recommend you to update to a newer OS with a up to date ISPConfig version.
     

Share This Page