Acpi disabled

Discussion in 'Installation/Configuration' started by lefteris, Aug 27, 2011.

  1. lefteris

    lefteris New Member

    It's my first post and I am newbie with Linux.
    However I have a Lenovo 3000 n500 with ubuntu natty and I cannot make acpi work!
    Can somebody offer some help over here ...?
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you get any error messages?

    What exactly have you tried so far?
  3. lefteris

    lefteris New Member

    I haven't tried much because most of the posts if found online lead to recompiling the kernel and I am not really confident in doing so ...
    However what I have noticed is that even though I have my "clode lid actions" to "Suspend" OR "Hibernate" when I open it back my computer restarts, and in some cases it alters the bios check screen to logo enabled OR disabled.
    Also after upgrading from lynx to natty (a couple of weeks ago) my battery duration from a couple of hours went down to 45'.
    Finally, some days ago, I found a command in order to check the acpi status (I don't remeber the command - does anyone?) and the outpout was that the acpi is disabled.
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you install the package acpi-support?

    Did you try
    in /etc/default/grub?
  5. lefteris

    lefteris New Member

    The package acpi-support is installed and I checked the grub file and I found that:


    Shall I simple change the "quiet splash" with "acpi=on" ??

    PS: what does quiet splash means?
  6. falko

    falko Super Moderator ISPConfig Developer

    Just add acpi=on to the existing options.

    For a black screen with boot processes displayed in text, remove "quiet splash". To see the grub splash image plus a condensed text output, use "splash".
  7. lefteris

    lefteris New Member

    thanks !!!
    It seems to work... but my bat is almost DEAD...! :mad:

    After closing the lid the machine came back to its previous state (in both cases close lid action=hibernate AND suspend).

    However do you know any command that will return me the state of the acpi(enabled/disabled) ?

    I remember that I had come across one, by that time, which returned me "acpi=disabled".

Share This Page