Accidentally removed files from server directory - how to get things working?

Discussion in 'Installation/Configuration' started by zabersoft, Sep 6, 2010.

  1. zabersoft

    zabersoft Member


    Ok, I messed up - I accidentally did a rm * on the /usr/local/ispconfig/server/ directory and now I can't get things quite back to status quo. Here's what I've done:

    Copied back all files from my ispconfig backup - Tried running and it complained about missing - I used the boilerplate and filled in the DB fields

    this "seemed" to get things working - now runs again and it says it is processing records, but it actually doesn't do anything (i.e. I am not getting all the debug messages I used to get, no DB/filesystem/FTP etc. is actually being created nor removed on the system)

    I am guessing I just need to tweak the config php some more - or that there are further missing files - I hope you can give me a rough heads up on what needs to do its job properly....

  2. zabersoft

    zabersoft Member

    BTW - This is the kind of output I am seeing now:

    06.09.2010-14:20 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    06.09.2010-14:20 - DEBUG - Found 2 changes, starting update process.
    06.09.2010-14:20 - DEBUG - Processed datalog_id 875
    06.09.2010-14:20 - DEBUG - Processed datalog_id 876
    06.09.2010-14:20 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
  3. zabersoft

    zabersoft Member

    It may not have been clear in my first post - but I restored the files in the server dir using fresh installation files - not a backup as I first wrote.

    I suspected that this was the cause of my problem - so I tried making a mirror of an existing (and working) installed server directory from another server to the one I messed up. This way I was sure I wasn't missing any files and that this would not be my problem.

    All I then did was I updated the so that the db password for user ispconfig was in order.

    But .... Same result. Server.php outputs the same as above (that is, it is processing records but gives no detail on operations as it used to, and outputs no errors)

    So I am in a situation where all the files that should be there are in order (I am almost 100% certain) and I cant really see anything besides the DB settings in that I would need to update - and those seem to be correct, otherwise server.php wouldn't pick up on the changes in the datalog.

    So what else is there.... Rights related issue maybe? I am getting a bit confused here ;)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    download ispconfig tar.gz, unpack it, run the update.php script and choose to reconfigure services during update.
  5. zabersoft

    zabersoft Member


    Thanks till - as usual you are a champ.

    I was going to update to the SVN in anyway to solve the problem with sites_web_domain_add so this worked out perfectly.

Share This Page