Accidentally nuked Postfix. Any chance on rebuilding the sql database?

Discussion in 'General' started by mcaramb, Jun 10, 2013.

  1. mcaramb

    mcaramb New Member

    I screwed up. I inadvertantly removed Postfix when I went to install Sendmail. Didn't realize it was an either/or situation. Thought I could run Sendmail separately, but apt pulled postfix and postfix_msql out during the install. After noticing this, I immediately reinstalled postfix, but now of course I think the db is lost.

    What can I do at this point? I'm in a blind panic right now. Clients aren't receiving email.

    THanks for any advice, and I apologize in advance for my stupidity.

  2. mcaramb

    mcaramb New Member

    Incidentally, the SMTP error i'm getting right now is during the RCPT TO command.

    RCPT TO:<[email protected]>
    451 4.3.5 <localhost.localdomain[]>: Client host rejected: Server configuration error

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Redo the postfix installation steps that were described in the ispconfig perfect setup guide that you used to install your server, then download the ispconfig tar.gz file, unpack it and run the update.php script which is in the install folder. Choose to reconfigure services during update.

    btw, why did you want to install sendmail? Postfix comes with a sendmail binary as wel, its a compatibility wrapper which is used by scripts to send emails. so no need to installs endmail for such a case.
  4. mcaramb

    mcaramb New Member

    any chance the process of running the update.php in ISPCONFIG will nuke everything else on the server? I'm really fearful of killing my website and settings.

    I needed to run sendmail in -bt mode which the postfix wrapper doesn't support. Was testing an email flow issue.

  5. mcaramb

    mcaramb New Member


    Thanks, I was simply missing a few postfix modules that needed installing which were described on the perfect server page.

    The config files and db were intact and didn't need the update.php to start working again. Mail is flowing...

    Thanks SOOOO much for your help


Share This Page