access do website without domain

Discussion in 'General' started by Tom John, Apr 13, 2019.

  1. Tom John

    Tom John Member HowtoForge Supporter

    Hi guys,
    i am running ispconfig 3 and ubuntu 18.04 with apache2 and i want to have access to my website without the domain is connected to the ip address, because now the domain is running on another server and i want to change the IP address when i already moved the website.
    in the browser it put:
    IPAddress/domainname but that does not work. As well i tried different other options like IPAddress/var/www/domainname but without success as well.

    can you give me some help please how to access my webspace?

    thanks in advance
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ISPConfig makes websites name based virtual sites, so IPAddress/domainname will not work. You have to have the website written in the browser address bar and then it goes to the website defined in ISPConfig.
    If you changed the IP-number of the server, use this method to test the website is working:
    https://www.faqforge.com/linux/cont...ess-a-namebased-website-without-a-dns-record/
    Once you have verified that works and the website is OK, then you can help other users access your site by changeing the FQDN in name service to point to your servers IP-number.
     
  3. Tom John

    Tom John Member HowtoForge Supporter

    thanks a lot for your answer, i changed that to the ip.
    Now the domain connects to the right server.
    But if i make a ping i get to the old server.
    the domain is discount-webdesign.com and the IP is 173.249.25.125
    I have wordpress installed on the new server with IP 173.....so i should get the wordpress welcome site, but if i put the domain name i get in the browserline the menu url of the old server : www.discount-webdesign.com/de/german
    so the page index.php for the wordpress setup does not appear.
    i dont know what is my problem?
    thanks a lot for your kind help
     
  4. ahrasis

    ahrasis Well-Known Member

    I think what you need is to add the ip of your ISPConfig server and the intended domain into your pc hosts file.
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you have other domain names or host names you want to point to your new server, put them all in the hosts file of your workstation.
    Your workstation can use many methods to resolve a FQDN to an IP-address. It can use DNS nameservice or look it up in the hosts file. These may give different answers. So it is possible to have a browser go to one place and ping pinging some other IP-number if they do not use the same name resolver.
    This Tutorial has a chapter on testing name service: https://www.howtoforge.com/tutorial/setting-up-your-own-name-service-with-ispconfig/#nbsptesting
    But what is confusing to me, is why do you not set name service to point to the IP-number you want? You wrote
    but the DNS name service shows otherwise:
    Code:
    $ host www.discount-webdesign.com
    www.discount-webdesign.com is an alias for discount-webdesign.com.
    discount-webdesign.com has address 68.66.248.21
    discount-webdesign.com mail is handled by 0 discount-webdesign.com.
    [email protected]:~
    $ host discount-webdesign.com
    discount-webdesign.com has address 68.66.248.21
    discount-webdesign.com mail is handled by 0 discount-webdesign.com.
    [email protected]:~
    $
    
    Also, I think you should have the MX record (the one that makes "mail is handled by 0 discount-webdesign.com") point to a hostname and not the domain name. So it should be something like mail.discount-webdisign.com or the FQDN of your mail host.
     
  6. Tom John

    Tom John Member HowtoForge Supporter

    Hi,
    first thank you for your really good answer. I will change the nameserver when i move the domain and as well i will have a look to the mx record.
    I changed the /etc/hosts on my local machine to : 173.249.25.125 www.discount-webdesign.com
    so now i have access to the new webspace with the IP 173..... it works.
    But and thats my next question:
    i installed with ISPConfig wordpress on that domain and in the /web dir i can see the wordpress files with index.php
    But when i put into the browser www.discount-webdesign.com i get an index.php from ispconfig instead of wordpress index.php

    Do you have an idea why i see in the /var/www/discount-webdesign.com/web directory with the terminal the wordpress files, but when i access with browser i see the index.html of ispconfig which i dont see in the terminal.

    Thanks so much for your kind help
     

    Attached Files:

  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Rename the index.html file to something else, or remove it.
    Or if that file does not exist, then apache is going to some other website. Examine apache logs to see which. Maybe alter the index.html there so you can verify which website is shown.
    Then check your certificates, you seem to use HTTPS and if certificates are wrong the websites may get mixed up.
     

Share This Page