"Access Denied! Your're address is blacklisted"

Discussion in 'Server Operation' started by tiamsanit, Dec 18, 2008.

  1. tiamsanit

    tiamsanit New Member

    I had setup ubuntu 8.04 server w/ispconfig followed howtoforge guide every stepa. It work well for a while but now I have complain from my customer who hosted website with my server. Someone cannot login or access PHP pages and display "Access Denied! Your're address is blacklisted". The error page is look like text file not contain any html tag and worng spell of "Your're". Sometime hit back and refresh solved the problem but not everytime. Error show on PHP page that contain login-password script, phpBB webboard when try to submit post or login. Does anyone face the same problem like me or has any ideas or solutions plese help. Thanks in advance.
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    So if I got this right, you are talking just that a phpBB is not working for a certain customer where you get this access denied message?
    Did you check whether the files of those phpBB look ok, as phpBB + plugins often got into attention regarding security flaws, maybe this is one.
    Or does this phpBB maybe have something like a flooding mechanism / Plugin, that blocks access from IP-Adresses spamming this forum or sth. similar?
     
  3. tiamsanit

    tiamsanit New Member

    The problem does not occurred only phpBB, but self made php login script sometime show up that error message. Only some of the visit and occasionally me, got the message when trying to login (self made script, no connection to phpBB) or post (phpBB).

    I think some of the php security modules is the cause, I am thinking that Suhosin is trouble one. I m trying to disable module for a while.
    I have search through google, some people do face the same problem with me, but only a few. (yea, "your're"!)

    Any suggestion?
     
    Last edited: Dec 19, 2008
  4. jbm

    jbm New Member

    Web access

    Sorry fox!
    I need help with accessing web and ssh out of my LAN. All request to web server are being dropped, denied or diconnected. within my LAN everything works. Router is properly configured to forward all requests port 80 to web server. Ubuntu 8.10 ... it is more than two weeks that I am trying to figure it out. I tried all possible application such as : desable ufw, ... :mad:
    pls ... anyone!? quick! ...

    jbm
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please open a new thread for this.
     
  6. tiamsanit

    tiamsanit New Member

    I had found out the cause of the problem. It is spamhaus! spamhaus' source file contain this nasty string "Access Denied! Your're address is blacklisted" so it must be spamhaus that do shit.
     
    Last edited: Dec 28, 2008
  7. Zjons

    Zjons New Member

    "Access Denied! Your're address is blacklisted" yo tengo ese problema desde que instale spamhaus, lo desactive y aun sigue apareciedo el aviso.

    I have the same problem "Access Denied! Your're address is blacklisted",I´ve disable the spamhaus module, but the problem persist.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you restart Apache?
     
  9. Zjons

    Zjons New Member

    Yes, I´ve restated the server
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    apache2 -M
    ?
     
  11. hvrossum

    hvrossum New Member

    I have the same problem with Spamhaus.

    When running the command
    apache2 -M

    I get the following reponse

    [email protected]:/home/harry# apache2 -M
    apache2: bad user name ${APACHE_RUN_USER}
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Please try
    Code:
    . /etc/apache2/envvars && apache2 -M
     

Share This Page