Access Denied on login

Discussion in 'Installation/Configuration' started by macawgumbo, Sep 25, 2006.

  1. macawgumbo

    macawgumbo New Member

    I successfully completed the install of ISPconfig. When it checked the root password for mysql it said successful, but now that I try to login from the web interface, I keep getting an access denied for 'root'@'localhost' in the mysql connect function in one of the php scripts the ISPConfig uses. Could somebody please help? I will post whatever is necessary.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that the mysql root password in the file /home/admispconfig/ispconfig/lib/ is correct and that your mysql daemon listens to network connections on localhost.
  3. macawgumbo

    macawgumbo New Member

    I checked that file and the root password is set to what it currently is. I can login to the mysql console with that password as well. I also did a netstat -tap and it show mysql listening:

    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 3960/mysqld

    What's weird is the fact that during the install is says 'ok' after checking the database at localhost with user root and the password. Any other ideas as to why it is failing to connect to MySQL?
  4. yahooadam

    yahooadam New Member

    there isn't a firewall between your ispconf server and mysql server (assuming that their on separate computers)

    this almost sounds like your trying to log into ispconf with your mysql details

    if so, the main account is admin and i think the password starts admin too

    if not, then pasting the error that comes up will be useful
  5. sas

    sas New Member

    I have the same problem with ispconfig.
  6. denmaus

    denmaus New Member

    defualt password

    Try to log-in with default User and Password:

    User: admin
    Password: ispconfig
  7. edge

    edge Active Member Moderator

    The default password is admin, and NOT ispconfig
  8. sas

    sas New Member

    Yes. Firstly I try to login with default


    and I have "ERROR 101: wrong username or password."
    then I try to logging with my system root login and password
    and also with my mysql root login and password but still has same error.

    It's must be my first login ; )

    my in section about database:

    === quote ===

    $go_info["server"]["db_host"] = "localhost";
    $go_info["server"]["db_name"] = "db_ispconfig";
    $go_info["server"]["db_user"] = "root";
    $go_info["server"]["db_password"] = "";
    $go_info["server"]["db_type"] = "mysql";

    === end ===


    netstat -tap | grep mysql

    tcp 0 0 *:mysql *:* LISTEN 2430/mysqld

    and my root mysql user has empty password and I succesfuly can logging to mysql with root and empty password.

    --- Updated ---

    And where I can manually change password for default user admin? In the shell of course.

    As i understand in first launch ispadmin scripts must automatically create database and tables? Or I something missed or do wrong in installation and databases was don't created? On what stage must be created DB and tables?
    Last edited: Sep 25, 2006
  9. macawgumbo

    macawgumbo New Member

    Everything runs on the same box. So I am connecting to MySQL running on localhost. A password is set and I can connect successful using

    #mysql -u root -p
    This is the output when I try and login with admin/admin at the ispconfig login page.

    Warning:  mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    Warning:  mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    Warning:  Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60
    I have checked the password in db_connect configuration file (forgot which one it is stored in) and it is set correctly. Like I said above, when testing the root password and connecting to localhost during setup it said successful until the very end when it was starting the ispconfig stuff and finishing up which is when it said it couldn't connect. It also says it can't connect when the service starts on boot.
  10. macawgumbo

    macawgumbo New Member

    I just checked the ispconfigdb and it show no tables or anything in there. I don't know if that is a problem or if they are created on first login. I also don't see the default /home/www was created. Once again I dont know when it is supposed to be created. Would a simple uninstall/reinstall work? If i cleared the root password (insecure) and bound mysql to localhost ( could that work properly and still be secure? Kinda would like to have this done by tomorrow evening.
  11. macawgumbo

    macawgumbo New Member

    Tried running the uninstall and errored out with:

    [email protected]:~/ispconfig# ./uninstall
    Could not connect to MySQL server!
    Is it okay to delete the directory /root/ispconfig (where I unzipped the original tarball and then go ahead and reextract (this time to /opt) and rerun setup? Or will it never work because ISPConfig has possibly the most finicky installation process?
  12. Rocky

    Rocky New Member

    If you're trying to uninstall ISPConfig, try this:


    Make sure that the ISPConfig mysql database is also removed then try to re-install.
  13. macawgumbo

    macawgumbo New Member

    I got it working the long way. I reinstalled everything from scratch following the perfect Ubuntu Setup guide. I then proceeded to install ispconfig. What I didn't do was set a password for mysql and kept the bind to address as

    It connected and I can login with no errors. So everything should be good. Nobody has access to this box except for me so the MySQL security isn't an issue. Plus it will only accept local connection which is all i need for ispconfig and the personal php/mysql development that i do.
  14. learning

    learning New Member

    Same here !!

    Had the same exact problems but did not receive a response from the forum after 24 hours (don't know what that means). But I was able to login using the default admin/admin login. But now I have other problems with the program since I keep getting "access denied' errors when the script tries to write to the ISPConfig configuration files.

    Bottom Line - Still not able to login with "root" as user NO MATTER WHAT I DO. So guess what? we're "SOL".


    Frustrated as well... :confused:
  15. macawgumbo

    macawgumbo New Member

    Here was my solution:

    Reinstall from scratch, everything. Then change the password for MySQL root before installing ISPConfig with PHPMyAdmin. I have had horrible luck with command line password crap. Then install ISPConfig. You could not set a root password, but definitely make sure its bound to if you do. (This is most insecure, don't do it). I installed Ubuntu Desktop actually with ISPconfig because I used it as a desktop environment / testing platform. And I never received a response from the forum on this til you came along... The only reason I saw it was because I guess I have reply emails enabled or something. Anyways good for you, I guess. :)
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    When the uninstall script fails, delete the directories /root/ispconfig, /home/admispconfig and the ISPConfig mysql database.
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    This is a free forum, there is no guarantee to get a response within 24 hours for every question. If you want to get a guaranteed response in time from the developers, you should consider to buy support.

    Without posting the exact errors message and where you got it, we are not able to provide a useful answer to your question.

    Login as root to which service, shell, ftp, mysql? You must login as root user with on the shell to start the ISPConfig installation.
  18. bwrob

    bwrob New Member

    On my fresh install Centos 4.4 ispconfig2.2.8
    i could not login cause my ispconfig_db was empty.
    So, i did >mysql -uxxx -pxxx ispconfig_db < db_ispcongig.sql
    then i could login admin|admin .
    Lol have another problem thought, now ispconfig wont save
    server settings.

  19. till

    till Super Moderator Staff Member ISPConfig Developer

    This wont work and is the reason for the problem that you can not save server settings.

    I guess you created the ISPConfig database manually before you run the setup, this results in a non functioning setup and a empty database.

    Please delete ISPConfig and the ispconfig database and run the setup again. make sure the mysql database does not exist before you run setup and that you use a mysql user that has priveliges to create databases.

Share This Page