Access Denied after installing ispconfig 3

Discussion in 'Installation/Configuration' started by soroush zendedel, Dec 19, 2018.

  1. soroush zendedel

    soroush zendedel New Member

    hi,
    i just installed an ispconfig3 on debian8, i didn't config a domain name yet and just using IP address,
    after opening my ip address with 8080 port:
    ***.***.***.***:8080
    i got:
    ---------------------------
    ERROR
    The requested URL could not be retrieved
    The following error was encountered while trying to retrieve the URL: ***.***.***.***:8080
    Access Denied.
    Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.
    ---------------------------
    what should i do? please help me.

    the log of installation:
    -------------------------------------------
    [email protected]:~# cat htf_report.txt

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1.13


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.6.39-0+deb8u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.39-0+deb8u1

    ##### PORT CHECK #####


    ##### MAIL SERVER CHECK #####


    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 1640)
    [INFO] I found the following mail server(s):
    Postfix (PID 1123)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 450)
    [INFO] I found the following imap server(s):
    Unknown process (init) (PID 1)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 1028)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:995 (450/dovecot)
    [localhost]:10023 (710/postgrey.pid)
    [localhost]:10024 (1228/amavisd-new)
    [localhost]:10025 (1123/master)
    [localhost]:10026 (1228/amavisd-new)
    [localhost]:10027 (1123/master)
    [anywhere]:587 (1123/master)
    [localhost]:11211 (432/memcached)
    [anywhere]:110 (450/dovecot)
    [anywhere]:143 (1/init)
    [anywhere]:111 (396/rpcbind)
    [anywhere]:465 (1123/master)
    [anywhere]:21 (1028/pure-ftpd)
    ***.***.***.***:53 (424/named)
    [localhost]:53 (424/named)
    [anywhere]:22 (534/sshd)
    [anywhere]:35478 (405/rpc.statd)
    [anywhere]:25 (1123/master)
    [localhost]:953 (424/named)
    [localhost]:6010 (546/0)
    [anywhere]:993 (1/init)
    *:*:*:*::*:995 (450/dovecot)
    *:*:*:*::*:41412 (405/rpc.statd)
    *:*:*:*::*:10023 (710/postgrey.pid)
    *:*:*:*::*:10024 (1228/amavisd-new)
    *:*:*:*::*:10026 (1228/amavisd-new)
    *:*:*:*::*:3306 (716/mysqld)
    *:*:*:*::*:587 (1123/master)
    [localhost]10 (450/dovecot)
    [localhost]43 (1/init)
    [localhost]11 (396/rpcbind)
    *:*:*:*::*:8080 (1640/apache2)
    *:*:*:*::*:80 (1640/apache2)
    *:*:*:*::*:8081 (1640/apache2)
    *:*:*:*::*:465 (1123/master)
    *:*:*:*::*:21 (1028/pure-ftpd)
    *:*:*:*::*:53 (424/named)
    *:*:*:*::*:22 (534/sshd)
    *:*:*:*::*:25 (1123/master)
    *:*:*:*::*:953 (424/named)
    *:*:*:*::*:6010 (546/0)
    *:*:*:*::*:443 (1640/apache2)
    *:*:*:*::*:993 (1/init)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-postfix-sasl tcp -- [anywhere]/0 [anywhere]/0 multiport dports 25
    fail2ban-dovecot-pop3imap tcp -- [anywhere]/0 [anywhere]/0 multiport dports 110,995,143,993
    fail2ban-pureftpd tcp -- [anywhere]/0 [anywhere]/0 multiport dports 21
    fail2ban-ssh tcp -- [anywhere]/0 [anywhere]/0 multiport dports 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-dovecot-pop3imap (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-postfix-sasl (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-pureftpd (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0
    ----------------------------------------
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I'm not sure ISPConfig installation works if no hostname and domain name is configured. You could invent some bogus FQDN and try installation again.
    Check the IP-number you used is the correct one. Check what IP-number the host uses.
    Maybe you made a mistake during installation? You do not say what Guide you used, but try again and be careful at each step.
     
    soroush zendedel likes this.
  3. soroush zendedel

    soroush zendedel New Member

    Thanks for your help,
    i used this instrucion:
    https://www.howtoforge.com/tutorial...n-8-jessie-apache-bind-dovecot-ispconfig-3/3/

    the VPS i used had a fresh debian8, and Domain name was not configured, nothing was configured and i just followed the instruction i mentioned.
    all the instructions has done but not FCGI because it's replaced in apache2.4 with something else.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you skipped the first two pages of that guide ISPConfig is not going to work.
     
  5. soroush zendedel

    soroush zendedel New Member

    id didn't skipped, apache is working fine, if you read the first post the installation is complately done.
    the webmail is working too.
     
  6. soroush zendedel

    soroush zendedel New Member

    solved, i figured it.
    if anybody have this problem do this steps:
    1- Uninstall ispconfig
    2- Install it with another port like :7654
    3- Do not use SSL

    Good luck
     
  7. Jesse Norell

    Jesse Norell Well-Known Member

    Glad you got your system working (mostly), but for anyone else reading this, step 3 "do not use ssl" may be bad advice, you certainly don't want to access your control panel over the internet in plain text. (I didn't even know the installer supported non-SSL installations ... or maybe you didn't follow the Perfect Server guide on some of your setup.)
     
  8. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    ispconfig works fine with port 8080 and ssl. either your ssl-cert failed or you are blocking port 8080 in the firewall.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    I agree to @florian030 and @Jesse Norell: Always use SSL and in your case, port 8080 was probably blocked by a firewall or claimed as port by your router and that's why it failed for you to use that port.
     
    soroush zendedel likes this.
  10. soroush zendedel

    soroush zendedel New Member

    Thank you for your help, I dont have a SSL Certificate, I am just testing to learn and use ISPconfig in future.
    I don't think without a SSL Certificate can i run my server in https, is that correct?
     
  11. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    the installer asks if you want https or not. if you choose no, you can not use https://IP:8080
    if you did not create a cert during the installation, there are no ssl-seetings written to config and you can use http://IP:8080
     
    soroush zendedel likes this.
  12. soroush zendedel

    soroush zendedel New Member

    It means i do not need to buy a SSL certificate from some where in the internet? can i have https without paying something and just config it in the installation of ISPconfig?
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

Share This Page