Access authenticating FTP sites using FTP Clients on XP clients via SQUID

Discussion in 'Server Operation' started by munirg2003, Jun 12, 2007.

  1. munirg2003

    munirg2003 New Member

    Hi There!


    - I have xp clients and Linux Server(having two LAN Cards Eth0-connected to my LAN and

    Eth1-connected to my WAN) with squid(configured at port 8080). Everything is working fine

    and internet is perfect on client machines. Even anonymous ftp sites are opening in

    internet explorer.But problem is to access my official ftp site with username and password.

    - I have some ftp client software i.e., old ws_ftp 95 or FileZilla to upload my data on my

    ftp website. These clients (using passive mode) work fine when i had Windows Server 2003

    with ISA server 2004. But our policy changed and now we use LINUX ES 4 with Squid 2.6

    stable for internet sharing.

    - Now when i use command based ftp on Linux server(Using #ftp ftp.mysite.com, It asks

    #UserName? and #Password?) it connects and uploads data. But when i try to connect from

    client XP machines either through command prompt or ftp client softwares, it doesn't

    connect.

    - Somebody told me to use iptables to open ports for forwarding your requests so i used

    following commands on Linux Server but failed.

    #iptables -A INPUT -s 192.168.7.0/24 -p tcp --dport 20 -j ACCEPT
    #iptables -A INPUT -s 192.168.7.0/24 -p tcp --dport 21 -j ACCEPT


    #iptables -A OUTPUT -d WAN-IP -p tcp --sport 20 -j ACCEPT
    #iptables -A OUTPUT -d WAN-IP -p tcp --sport 21 -j ACCEPT

    #iptables -A FORWARD -s 192.168.7.0/24 -d WAN-IP -p tcp --dport 20 -j ACCEPT
    #iptables -A FORWARD -s 192.168.7.0/24 -d WAN-IP -p tcp --dport 21 -j ACCEPT

    #service iptables save

    - Somebody sujjested to use frox, again i tried but failed.

    - Somebody help me in easy steps please.


    Munir Ahmad
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client(s)?
     
  3. munirg2003

    munirg2003 New Member

    Many times but failed.

    Yes many times i tried but all in vain.

    My problem authenticating Ftp access through clients is still pending!!!!
     

Share This Page