Accepting larger mail

Discussion in 'Tips/Tricks/Mods' started by cozened, May 21, 2010.

  1. cozened

    cozened New Member

    Good day,

    I simply cant find anything about this, where do I configure the limit of files / mails the system accepts? (using ISPConfig 3 on Debian Lenny)

    Users are complaining about this so I need to make the limit bigger.

    What generally are people using for there customers?

    With best regards
  2. Hans

    Hans Moderator ISPConfig Developer

    First read out the value of your current message_size_limit with the command postconf | grep message_size_limit

    If needed, you can change the value of message_size_limit by editing the postfix configuration file /etc/postfix/
    TWo examples:

    #Accept maximum 10MB:
    message_size_limit = 10240000
    message_size_limit = 0
    After changing your postfix configuration file, you reload postfix:
    /etc/init.d/postfix reload

    If you have a webmail client installed on your server and you want to send bigger attachments with it, also change the values of post_max_size & upload_max_filesize in your php.ini file.


    ; Maximum size of POST data that PHP will accept.
    post_max_size = 10M
    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 10M

    After changing your php.ini file, reload apache with:
    /etc/init.d/apache2 reload
    Last edited: May 21, 2010
  3. cozened

    cozened New Member

    Thank you Hans.

    I could grep the size limit , and it was 10240000 but I could not see it in the file itself so I just put a line there "messages_size_limit = 0" and reload it.

    Grep it again and it said it was 0 so now I'm trying to send a 100mb file (realy extreme I know but just trying :))

    Just so other people will know if they wanna do this , if the line is missing you just add it to the file

    The php settings where something I needed aswell except I found the php.ini file in /etc/php5/apache2/php.ini and changed there those values but I stil cant to seem to see the change in roundcube (by trying to upload a file)

    Is that the right config file or ?

    with best regards
  4. Hans

    Hans Moderator ISPConfig Developer

    The default size limit for Postfix is 10MB, so you only need to define a value for "messages_size_limit" if it is different then 10 MB.

    Depending on which php mode you're using.
    You can also increase the value for post_max_size & upload_max_filesize within the files /etc/php5/cgi/php.ini and /etc/php5/cli/php.ini. Of course if your website uses its own php.ini file, you have to make you're modifications there.
    Last edited: May 22, 2010
  5. cozened

    cozened New Member

    Hi Hans,

    Thank you! that did the trick :)

    now everything is working smoothly, thanks again!

    best regards

Share This Page