about php-fpm

Discussion in 'Installation/Configuration' started by Maslak Yavuz, Feb 6, 2019.

  1. Maslak Yavuz

    Maslak Yavuz Member

    i use ispconfig3.1 on ubuntu16.04.
    i configured php-fpm for multiple php versions.
    when i switch to php7.2 for a webpage, i get the error 500. on the the page's error log as following
    [Wed Feb 06 09:41:19.896399 2019] [fastcgi:error] [pid 12525] (20)Not a directory: [client 10.11.1.112:60052] FastCGI: failed to connect to server "/var/www/clients/client51/web89/cgi-bin/php-fcgi-*-80-abc1.com": connect() failed
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Need a little more info like how you installed the additional php versions, by compiling yourself or using pre-compiled repo. If compiling your own, run back through the tutorial on how to set that up and check each step and each config file/init script/setting to make sure they look right, including running the commands to install everything again. If using php from the sury.org repos, verify you have all packages installed again (eg. you have php7.2-cgi for fastcgi mode?) and verify the additional php settings in ispconfig.
     
  3. Maslak Yavuz

    Maslak Yavuz Member

    I followed the link (https://www.howtoforge.com/tutorial/how-to-install-php-5.6-and-7.1-on-debian-9-stretch/) to add the features.
     

Share This Page