About installing ISPConfig

Discussion in 'Server Operation' started by satimis, Dec 3, 2007.

  1. satimis

    satimis New Member

    Hi folks,

    Ubuntu 7.04 server amd64

    I need to install ISPConfig on the captioned mail server and could not find the package on repo NOR relevant tutorial on googling. Please advise whether it is not available on repo. I have to install it on;


    where can I find its installation manual?

    The necessity installing ISPConfig is to follow;


    their steps to make roundcube to work. I have it running here but can't make it to work.


  2. wpwood3

    wpwood3 New Member

    If you are running webmin then you cannot install ispconfig. They perform the same task which is system administration. You should pick one or the other.

    The ispconfig installation manual can be found here:
  3. satimis

    satimis New Member

    Thanks for your advice.

    Webmin is running here. It can be evoked with;


    and login as root.

    However I can't figure out how to perforem step-1 of:-


    on Webmin;
    Step 1 - Create a website:
    In ISPConfig, create a website via “New site” in the main menu. 
    On the tab called “Basis” use webmail for the hostname and 
    myhostingcompany.tld for the domain name. Enable MySQL and 
    PHP scripts for this website but disable PHP Safe Mode. 
    Any advice? TIA

  4. till

    till Super Moderator

    You must create the website in ISPConfig and not webmin as a website setup with webmin will collide with ISPConfig as wpwood3 pointed out.
  5. satimis

    satimis New Member

    Hi till,

    I'm a little bid confused here. If I understand wpwood3's advice correctly then I can't run both of them, ISPConfig and Webmin, concurrently. In such situation I won't install the former. But how can I create a website on Webmin to compile Step-1?

  6. till

    till Super Moderator

    Yes, because both are doing the same configuration and this causes a conflict..

    Please have a look at the tutorial that you linked above, it explains clearly that you have to use ISPConfig and not webmin to create the website.
  7. satimis

    satimis New Member

    Thanks for your advice.

    I need webmin and usermin here particularly allowing users to change password remotely. In such a circumstance I have to googling another tutorial. Or switch to Squirrelmail.

  8. till

    till Super Moderator

    Users can do this with ISPConfig as well trough the mailuser login:

  9. satimis

    satimis New Member


    All server not found. What is "tld" here?

    I'm running Linus users here NOT virtuall users. Shall I make any change here and how? Thanks.

    Besides does it need port 81? If YES, I have to check with ISP whether port 81 has been blocked. My ISP has blocked many ports. I have to calling them to uplift the port which I need.


    Checked with ISP, port 81 has NOT been blocked

    Last edited: Dec 3, 2007
  10. wpwood3

    wpwood3 New Member

    tld = "Top Level Domain"
    Examples - .com, .net, .org, .biz, .gov
  11. falko

    falko Super Moderator

    Please make sure that www.domain.com is pointing to the correct server. You can check that with
    dig www.domain.com
    Also, what's the output of
    netstat -tap
  12. satimis

    satimis New Member

    Hi falko,

    I found the cause of the problem coming on iptables.

    After running;

    $ sudo iptables -F


    Not Found
    The requested URL /mailuser was not found on this server.


    start with following warning popup;
    security Error: Domain Name Mismatch
    You have attempted to establish a connection with
    "www.satimis.com".  However, the security certificate
    presented belongs to "localhost".  It is possible though
    unlikely, that someone may be trying to intercept your
    communication with this website.
    If you suspect the certicate shown does not belong to
    "www.satimis.com". please cancel the connection and notify
    the site administrator.
    [Vies Certificate]     [Cancel]  [OK]

    Clicking [OK] popup;
    Not Found
    The requested URL /stephen was not found on this server.

    $ dig www.satimis.com
    ; <<>> DiG 9.3.4 <<>> www.satimis.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25300
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 2
    ;www.satimis.com.               IN      A
    www.satimis.com.        2846    IN      CNAME   satimis.com.
    satimis.com.            2733    IN      A
    satimis.com.            2733    IN      NS      ns43.domaincontrol.com.
    satimis.com.            2733    IN      NS      ns44.domaincontrol.com.
    ns43.domaincontrol.com. 209     IN      A
    ns44.domaincontrol.com. 9       IN      A
    ;; Query time: 21 msec
    ;; SERVER:
    ;; WHEN: Wed Dec  5 11:13:19 2007
    ;; MSG SIZE  rcvd: 147

    $ netstat -tap
    (Not all processes could be identified, non-owned process info
     will not be shown, you would have to be root to see it all.)
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
    tcp        0      0 *:20000                 *:*                     LISTEN     -                   
    tcp        0      0 *:vmware-authd          *:*                     LISTEN     -                   
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     -                   
    tcp        0      0 *:8333                  *:*                     LISTEN     -                   
    tcp        0      0 *:webmin                *:*                     LISTEN     -                   
    tcp        0      0 *:www                   *:*                     LISTEN     -                   
    tcp        0      0 *:ftp                   *:*                     LISTEN     -                   
    tcp        0      0 mail.satimis.com:domain *:*                     LISTEN     -                   
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     -                   
    tcp        0      0 mail.satimis.com:ssh    *:*                     LISTEN     -                   
    tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN     -                   
    tcp        0      0 *:smtp                  *:*                     LISTEN     -                   
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     -                   
    tcp        0      0 *:https                 *:*                     LISTEN     -                   
    tcp        0      0 *:8222                  *:*                     LISTEN     -                   
    tcp6       0      0 *:imaps                 *:*                     LISTEN     -                   
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     -                   
    tcp6       0      0 *:pop3                  *:*                     LISTEN     -                   
    tcp6       0      0 *:imap2                 *:*                     LISTEN     -                   
    tcp6       0      0 *:domain                *:*                     LISTEN     -                   
    tcp6       0      0 *:smtp                  *:*                     LISTEN     -                   
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     -       

    Last edited: Dec 5, 2007
  13. falko

    falko Super Moderator

    It must be https://satimis.com:81/mailuser or https://localhost:81/mailuser
  14. satimis

    satimis New Member

    Both failed.

    Unable to connect
    Firefox can't establish a connection to the server at satimis.com:81.
    OR ........ at localhost:81

    Checked with ISP. Port 81 is open.

  15. falko

    falko Super Moderator

  16. satimis

    satimis New Member

  17. kenlec

    kenlec New Member

    i hv done the installation but i cannot login the administrator account.

    i notice my mysql db is empty

    please advice

  18. falko

    falko Super Moderator

    Please open a new thread for this.

Share This Page