AACHE2/PHP5 quirk

Discussion in 'Server Operation' started by tmaleshafske, May 18, 2008.

  1. tmaleshafske

    tmaleshafske New Member

    I just got done installing a xen server on Hardy 8.04 LTS, which works great. I had no problems with the installation of the virtual machines. I was trying to bring my web server back up on line on a virtual machine following the Hardy Perfect Server How To. minus a lot of the unnecessary: bind, mysql, etc..

    I have installed Egroupware. When I go to click the link to create the databases via the web-based set-up it immediately moves me back to the login screen. I believe that this is a problem with my PHP installation, but I am unsure of where. I have looked both at the apache2 access.log and the error.log and it doesn't show any errors as to why the unusual behavior

    Note: my sql installation sets on a different server
    Appreciate the assistance ahead of time.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does the MySQL server allow remote logins? Can you try to connect to it from the shell?
     
  3. tmaleshafske

    tmaleshafske New Member

    No issues with logging in remotely. to the Mysql server. In fact I have a installation of Website Baker feeding off of it right now. It is almost like I don't have an Apache2 module that I need loaded or there is a problem with my php.ini file. But I don't see where
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you install the php5-mysql package?
     
  5. tmaleshafske

    tmaleshafske New Member

    Yes I did. Even using XAMPP i have the same problem...Could this be a problem with hardy or the fact I am using a XEN virtual Machine
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Is extension=mysql.so listed in your php.ini (or in one of the included files)?

    You can build the following PHP page:
    PHP:
    <?php
    phpinfo
    ();
    ?>
    and call it in a browser - is MySQL mentioned on that page?
     

Share This Page