A server setting causing problems in Joomla!

Discussion in 'Server Operation' started by dimas, Jul 1, 2009.

  1. dimas

    dimas Member

    I have a server with freshly installed ISPConfig 2.2.32 (Perfect Setup), Debian Lenny.

    I moved a number of Joomla! sites to it from my old server (manually, like I did countless times with no problems), and here's what happened - in the Joomla! administration section (of any Joomla! site, any version), if I assign a module to a certain number of menu items (in my case the number should be more than 180 for the error to appear) and click save or apply - then I get the "invalid token" message on a blank page.

    The message appears not every time when I try to apply or save changes - sometimes I'm just redirected to the main page of the Joomla! administration section (and no changes are saved).

    If the number of items is less than 180 - everything's OK. It's also OK if I choose all items (no matter what the number).

    I also tried the same with a freshly istalled Joomla! (with no extra modules/components/plugins), with the same results. The template I used was very simple and self-made (I'm sure it's OK), all the file/folder permissions are OK (green).

    So I believe that some server setting is causing this error, or possibly php version? The php version is now 5.2.6.

    I would be extremely grateful if someone gives an idea what server setting causes this behavior, because many of my clients are complaining.

    Please note that I asked this question at the official Joomla forum, but so far nobody has suggested anything useful.
  2. dimas

    dimas Member

    It is now solved - the perpetrator was Suhosin - and the solution was initially provided by light-blue at the end of the Perfect Setup for Debian Lenny.

Share This Page