A really newbie need help

Discussion in 'General' started by jpchalifoux, Feb 10, 2007.

  1. jpchalifoux

    jpchalifoux New Member

    Hi
    1 month ago i know nothing about linux, ispconfig,and all i need to have a web server and hosting website for a few non profit organisation here in Montreal. So i manage to install Unbutu 6.10 and ispconfig on a old machine that i have (PIII 800 512 meg 180g hd etc...) Everything went perfectly well installing ispconfig following instruction of The Perfect setting of Ispconfig on a Ubuntu server.........................)

    I have a domain name enxxxxxxxxxxxx.ca

    My registar have register my name server pointing to my static ip address.

    The server use internal adress of my router 192.168.2.xxx, i have open the port 21 thru 110 on my router to point out to my internal ip address. So far everything is working perfectly when i type my domain name enxxxxxxx.ca i see a page on the web.

    The problem is when i create a customer (my friend in fact) and is web site on ISPconfig, and i try to reach is web site nothing append.

    He has in fact register my nameserver to is registar, pointing to my server ns1.enxxxxxxxxxx.ca and ns2.enxxxxxxxxxxx.ca

    Can somebody help me in a simple non-expert language on this matter pls

    Thanks in advance, i hope i've give enough information.
     
  2. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Code:
    The problem is when i create a customer (my friend in fact) and is web site on ISPconfig, and i try to reach is web site nothing append.
    Don't you see anything?
    I am also a linux newbie with ISPConfig installed on my server. And had an simular problem in the beginning. My other site was pointing to an shared ip adress. That was what I saw on the net.

    That was solved with the use of the "create dns" on the basis tab. did you enable that one.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    dig yourfriendsdomain.com
    Does it point to the correct IP address?
     
  4. jpchalifoux

    jpchalifoux New Member

    Here what i got from dig

    ; <<>> DiG 9.3.2 <<>> paxxxx.net
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 19173
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;paxxxx.net. IN A

    ;; Query time: 214 msec
    ;; SERVER: 192.168.2.1#53(192.168.2.1)
    ;; WHEN: Sun Feb 11 14:41:21 2007
    ;; MSG SIZE rcvd: 29

    But the right adress is suppose to be 192.168.2.199 and not 192.168.2.1

    192.168.2.1 is the adress of the gateway
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The gaetway is queried if your local DNS server is not authoritive for the domain.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    There's no answer section, so there's no A record for the domain. Please create one, and make it point to a public IP address, not a local one.
     

Share This Page