A quick newbie question...

Discussion in 'Installation/Configuration' started by viriiguy, Jun 19, 2006.

  1. viriiguy

    viriiguy New Member

    Hello all, I have followed all the instructions for Mandriva 2006 and now have ISPConfig installed and working :) WooHooo.

    But let's say I am set up at www.example.com. How do I assign a user the address of www.example.com as a webpage? and how do I also assign subdomain1.example.com to another person.

    Currently I cannot figure out how to assign www to a user one way or the other, since ISPConfig is set to use it. I have tried changing ISPConfig from www to cnf under Management->server->settings->hostname, But this seems to change nothing. What am I missing?

    Thank you
  2. brainz

    brainz Member

    Hi viriiguy

    Read this thread this will help you understand...... the whole concept


    brainz ;):cool:
  3. erk

    erk New Member HowtoForge Supporter

    I'm not sure I understand exactly what you want to accomplish.
    My guess is that what you want is for one user to have ftp access to www.example.com to manage that website and another user to have ftp access to xyz.example.com.

    To do this you must create two websites. One with hostname www and domain example.com and one with hostname xyz and domain example.com.
    There can only be one user with adminrights for each site and only the admin has ftp access to the web/ directory.

    Another thing, when you create two websites with the same domain (example.com) they must be assigned to the same customer.

  4. brainz

    brainz Member

    I think what viriiguy is trying to do is to understand the concepts behind ispconfig and how it works and then how to set it up with the dns web accounts etc.....

    brainz ;):cool:
  5. viriiguy

    viriiguy New Member

    Ok I THINK erk is on the same path as me.
    I only have one domain. When I set up ISPConfig I followed the instructions and gave ISPConfig the hostname www for this domain. I have also setup 4 ips by making an eth0:0 eth0:1 eth0:2 and eth0:3 and then in my router forwarded port 80 to each of them.

    I have been able to succesfully create a new client (my wife) and assign her a hostname on my domain. we will call it sneezer.example.com. So what you are saying is that since I assigned www.example.com to ispconfig, only the admin can control the website that shows up on WWW.example.com and my wife can control sneezer.example.com right? If so this is fine, since I am the admin.

    Thank you all,
  6. brainz

    brainz Member

    Hi viriiguy

    Thankyou for explaining your issue a little more...

    I read it and need to say that this is not how to use the subdomains with ispconfig with the the eth0:0 eth0:1 etc these part of the prefect howto setup so the server has 2 ip address which is need for the dns server eth0:0 main ip address or server eth0:1 backup ip address or server.

    What i recommened you do is setup the server and ispconfig excatly the way it is shown in the howto and ispconfig....

    then within the ispconfig admin logon configuration there you can setup a domain and subdomains.....

    brainz :rolleyes::cool:
  7. viriiguy

    viriiguy New Member

    Ok that is no problem. And thank you for explaining the reason for the eth0:0 etc etc etc. But now the problem is that if I try to set up a website using www.example.com it tells me this address is in use by another webserver.

    So I assume this is because during the setup of ispconfig I told it the hostname was www. So therefore ispconfig is using the www. But I would like to have my MAIN site at www. Am I making any sense?

    Thank you again.
  8. brainz

    brainz Member

    Yes you are making sense however if you have tried to setup the domain once and deleted it....

    Well deleting it does not mean it is deleted it means that the all the setting and all the items have been move to the recycle bin,

    You need to goto the recycle bin and empty the recycle bin....

    also when setting up a domain in ispconfig you dont put the www in its just domain.tld...

    Also this is good reading http://www.howtoforge.com/traditional_dns_howto

    Then theres this explination by falko http://www.howtoforge.com/forums/showpost.php?p=6292&postcount=4

    and a till explination

    Another till explination that made the most sense to me.....

    brainz ;):cool:
    Last edited: Jun 19, 2006
  9. falko

    falko Super Moderator ISPConfig Developer

    You can forward a port to only one IP address!

    This has nothing to do with the address you used to install ISPConfig. I guess you set up www.example.com as a web site in ISPConfig, and then you tried to create the same web site again without deleting the other one. That does not work. You must delete the other one (you must also delete it from the recycle bin) before you can create the new one.

    However, it's recommended that you don't use an FQDN for ISPConfig that you also want to use for a web site: http://www.howtoforge.com/faq/14_33_en.html
  10. viriiguy

    viriiguy New Member

    Sorry for the delay, went camping for a couple days.

    Thank you very very much for the responses :) The trashcan was the problem. So I now have both set up, and if my other domain EVER transfers to me. I will be able to add it. Thank you again the links were a great read, and I now have a much better understanding of the program.

Share This Page