A newbie with dns and ispconfig questions

Discussion in 'Installation/Configuration' started by munika, Nov 20, 2006.

  1. munika

    munika New Member

    hi guys,
    thankyou very much. With the help of howtoforge and ispconfig and all the helpfull tutorials i have successfully setup a machine at my place. i have bough a domain name from 1and1.com and have linked it to start mydomain.net:81 the admin page.

    question.
    1. how can i put that domain name www.mydomain.net on ispconfig so that i can get all the features like mailboxes and webspace and all to that machine.
    Currently when i do www.mydomain.net:81 i do get admin page and when i log in i can do all the things. is there a way i can say www.mydomain.net to make it as a website in ispconfig.

    2. also my domain name registrar has given me one mailbox. on his control panel i can change the mx record. what is mx record what do i change the mx record to.

    3. i have friends who have several domain names and we want to host it on to that machine. the domain names have been bought from other domain registrars. how can we point those domain names to this server and start using mailboxes, ftp, webspace. Is there a tutorial about that.

    sorry forgot to mention.
    i am p3 machine with fedora core 5 then i followed www.howtoforge.com FC5 perfect setup and then ISPCONFIG setup on www.ispconfig.org.

    thankyou
    and keep up all the good work.

    munika.
     
    Last edited: Nov 20, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Create a new website www.mydomain.net. Make sure that www.mydomain.net points to the IP of your server with an DNS A_Record.

    2) Set the MX record to the hostname of your server.

    3) Login to the controlpanels of these registrars and create DNS A-Records for the domains that point to your server IP address. You can run your own nameserver, but thats more complicated and for the beginning its better if you use the nameservers of your registrar.
     
  3. munika

    munika New Member

    Thankyou

    Thankyou very much.
    i pointed the ip addresses and thats fine for the domain names.
    i am confused with the mx record. Your reply says hostname of the server as the mx record.

    what is the hostname. Is it the FQDN through which i access my *:81 ie. www.keshwani.net. is it.

    thanks for the reply
    munika
     
  4. munika

    munika New Member

    cannot receive emails

    hi,
    I have configured my mx record as test.keshwani.net and priority is 1 on 1and1.com (my domain name provider) I created 2 accounts through ispconfig [email protected] and [email protected]. i used both the accounts in my outlook just for testing.
    I clicked on the test account settings button it works fine.

    For testing i tried to send email through [email protected] to [email protected]. my outlook says it is sent. so now i should received it under [email protected]. I didnot receive it under [email protected]. Is there someway I can trouble shoot.

    I have just tried sending it internal. will try to send it outside something like [email protected]

    also when i give my email to others what will be my email address will it be [email protected]

    ispconfig did ask me email address [email protected] i tried to put that in outlook it doesnt work.

    any ideas.

    thanks
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I meant the fqdn.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up the username and email address:

    web1_shirin is the username. You must use this username and the password to authenticate for pop3 and smtp.

    [email protected] is your email address.

    Did you enable the maildir checkbox in ISPConfig under management > server > settings? Which messages do you get in the mail logfile, when you send mail?
     
  7. munika

    munika New Member

    My mail log

    hi,
    i have attached a maillog.txt file i see something like hostname not proper and port 25 connection timed out.

    is that the problem.

    how do i fix the connection timed out problem.

    thanks

    munir
     

    Attached Files:

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    It looks like your server is not able to connect on port 25 to other servers. Please check your firewall and ask your provider if they block connections on port 25.
     
  9. munika

    munika New Member

    router status

    hi till,
    I have checked the router status and ports. Ther server is under DMZ zone so all the ports are open.

    Also i have attached a maillog with this message. I see a line in this which says [email protected]. not sure if that is a problem.

    Also i found this line

    Nov 23 09:51:02 newlocal postfix/smtp[31395]: 516DC14F15C: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=test.keshwani.net type=A: Host not found)

    Just for your info. i have a domain name www.keshwani.net with 1and1.com and have redirected to the ip address of ispconfig server. also i have made a sub domain test.keshwani.net and redirected to ispconfig server. also mx record forwarded to ispconfig server.

    In the email client i got this email from server .


    Your message did not reach some or all of the intended recipients.

    Subject: hi
    Sent: 23/11/2006 9:47 AM

    The following recipient(s) could not be reached:

    '[email protected]' on 23/11/2006 9:47 AM
    554 <[email protected]>: Relay access denied

    thankyou
    munika
     

    Attached Files:

    Last edited: Nov 23, 2006
  10. falko

    falko Super Moderator ISPConfig Developer

    It can take up to 72 hours until DNS changes propagate, so if this is a new record it could work now (at least I got this which looks ok:

    Code:
    mh1:~# dig test.keshwani.net
    
    ; <<>> DiG 9.2.1 <<>> test.keshwani.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64168
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;test.keshwani.net.             IN      A
    
    ;; ANSWER SECTION:
    test.keshwani.net.      86400   IN      A       69.199.86.130
    
    ;; Query time: 150 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Nov 24 16:11:12 2006
    ;; MSG SIZE  rcvd: 51
    ).

    Please make sure you enabled "Server requires authentication." in your email client.

    And check if your server is blacklisted: http://www.mxtoolbox.com/blacklists.aspx
     
  11. munika

    munika New Member

    hi friends,
    i did check mxtoolbox and in diagnostics i got this result


    RESULT: test.keshwani.net
    Banner: test.keshwani.net ESMTP Postfix [812 ms]
    Connect Time: 0.062 seconds - Good
    Transaction Time: 1.281 seconds - Good
    Relay Check: OK - This server is not an open relay.
    Rev DNS Check: OK - 74.102.252.2 resolves to cpe000f6636692c-cm001225dfe66c.cpe.net.cable.rogers.com
    GeoCode Info: Geocoding server is unavailable
    Session Transcript: HELO mxtoolbox.com - DIAGNOSTIC TEST - See http://www.mxtoolbox.com/Policy.aspx
    250 test.keshwani.net [62 ms]
    HELO mxtoolbox.com
    250 test.keshwani.net [62 ms]
    MAIL FROM: <[email protected]>
    250 Ok [125 ms]
    RCPT TO: <[email protected]>
    554 <[email protected]>: Relay access denied [78 ms]
    QUIT
    221 Bye [78 ms]



    11/25/2006 12:32:32 PM Central Standard Time




    Relay access denied not sure what to do.
    i tried "server requires authentication" but it didnt work.

    i have few computers in the same network so atleast i should be able to get [email protected] send an email to [email protected] but that too doesnt work. munir can send it but shirin cannot receive it. also shirin can send it but munir cannot receive it.

    thanks

    munika
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Is keshwani.net listed in /etc/postfix/local-host-names? What's in /etc/postfix/main.cf (please strip out the comments)?
     
  13. pcotter

    pcotter New Member

    Cant send or receive email trough Webmail

    I there

    I'm unable to receive or send emails trough Uebimiau Webmail. Not sure what to do...:confused: If i use Outlook i can send (tested with Hotmail), but not receive. With Webmail i can neither receive or send...
    (used The Perfect Setup - Debian Sarge (3.1))
    Please help!

    ###################################
    #
    # ISPConfig local-host-names Configuration File
    # Version 1.0
    #
    ###################################
    localhost
    cotter-server.pcotter.com
    localhost.cotter-server.pcotter.com
    localhost.pcotter.com
    localhost.localdomain
    www.pcotter.com
    foto.pcotter.com
    deptec.pcotter.com
    soenke.pcotter.com
    pcotter.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

    /etc/postfix/main.cf
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    myhostname = cotter-server.pcotter.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = cotter-server.pcotter.com, localhost.pcotter.com, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    "/etc/postfix/main.cf" 44L, 1382C
     
    Last edited: Dec 10, 2006
  14. pcotter

    pcotter New Member

    Uff!!! I tried a so many things from this forum and nothing helped!!!!:eek:

    Someone please??!?!?
     
  15. falko

    falko Super Moderator ISPConfig Developer

Share This Page